aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:16:48 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:16:48 +0800
commit66557209cbab57fdb574f13f2abdf184cd700f61 (patch)
tree63ab58336d65102986aafd0660ede6382de9a754 /security
parent30cd79ca358540d1b96c3c637f6d0e22ab2bd6bc (diff)
downloadfreebsd-ports-gnome-66557209cbab57fdb574f13f2abdf184cd700f61.tar.gz
freebsd-ports-gnome-66557209cbab57fdb574f13f2abdf184cd700f61.tar.zst
freebsd-ports-gnome-66557209cbab57fdb574f13f2abdf184cd700f61.zip
The murmur hash algorithm by Austin Appleby is an exteremely fast
algorithm that combines both excellent collision resistence and distribution characteristics. WWW: http://search.cpan.org/dist/Digest-MurmurHash/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-MurmurHash/Makefile21
-rw-r--r--security/p5-Digest-MurmurHash/distinfo2
-rw-r--r--security/p5-Digest-MurmurHash/pkg-descr5
-rw-r--r--security/p5-Digest-MurmurHash/pkg-plist7
5 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8b82ac4c5835..ea268a2f6433 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -497,6 +497,7 @@
SUBDIR += p5-Digest-MD5-M4p
SUBDIR += p5-Digest-MD5-Reverse
SUBDIR += p5-Digest-ManberHash
+ SUBDIR += p5-Digest-MurmurHash
SUBDIR += p5-Digest-Nilsimsa
SUBDIR += p5-Digest-Pearson
SUBDIR += p5-Digest-Pearson-PurePerl
diff --git a/security/p5-Digest-MurmurHash/Makefile b/security/p5-Digest-MurmurHash/Makefile
new file mode 100644
index 000000000000..31b6f3593285
--- /dev/null
+++ b/security/p5-Digest-MurmurHash/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Digest::MurmurHash
+# Date created: 31 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Digest-MurmurHash
+PORTVERSION= 0.11
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for XS interface to the MurmurHash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::MurmurHash.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-MurmurHash/distinfo b/security/p5-Digest-MurmurHash/distinfo
new file mode 100644
index 000000000000..9beaf9ddb557
--- /dev/null
+++ b/security/p5-Digest-MurmurHash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Digest-MurmurHash-0.11.tar.gz) = 613ee3f2e46d91be28187499faf1aaebfcf4859843b7a4a3c9839d67aed6980f
+SIZE (Digest-MurmurHash-0.11.tar.gz) = 32635
diff --git a/security/p5-Digest-MurmurHash/pkg-descr b/security/p5-Digest-MurmurHash/pkg-descr
new file mode 100644
index 000000000000..f5b79f269ea9
--- /dev/null
+++ b/security/p5-Digest-MurmurHash/pkg-descr
@@ -0,0 +1,5 @@
+The murmur hash algorithm by Austin Appleby is an exteremely fast
+algorithm that combines both excellent collision resistence and
+distribution characteristics.
+
+WWW: http://search.cpan.org/dist/Digest-MurmurHash/
diff --git a/security/p5-Digest-MurmurHash/pkg-plist b/security/p5-Digest-MurmurHash/pkg-plist
new file mode 100644
index 000000000000..6fcecb71e673
--- /dev/null
+++ b/security/p5-Digest-MurmurHash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/MurmurHash/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/MurmurHash/MurmurHash.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/MurmurHash/MurmurHash.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/MurmurHash.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Digest
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/MurmurHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest