aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-05-28 17:14:48 +0800
committerjohans <johans@FreeBSD.org>2014-05-28 17:14:48 +0800
commit66d4edd2f7d8b0414a035a5e453a5123355fd934 (patch)
tree4c027fa2ee4e36e905bb1564e95dbaebb6f4b765 /security
parentc2c62654e8fdbbeaaccf5d4630bba0303d00e1f6 (diff)
downloadfreebsd-ports-gnome-66d4edd2f7d8b0414a035a5e453a5123355fd934.tar.gz
freebsd-ports-gnome-66d4edd2f7d8b0414a035a5e453a5123355fd934.tar.zst
freebsd-ports-gnome-66d4edd2f7d8b0414a035a5e453a5123355fd934.zip
- Update to lsh 2.1
- Stagify - Adopt port
Diffstat (limited to 'security')
-rw-r--r--security/lsh/Makefile55
-rw-r--r--security/lsh/distinfo4
-rw-r--r--security/lsh/files/patch-nettle-openssl.c10
-rw-r--r--security/lsh/pkg-plist60
4 files changed, 39 insertions, 90 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index 172f4902249c..793d80c43dc5 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -2,50 +2,31 @@
# $FreeBSD$
PORTNAME= lsh
-PORTVERSION= 2.0.4
-PORTREVISION= 6
+PORTVERSION= 2.1
CATEGORIES= security ipv6
-MASTER_SITES= ${MASTER_SITE_GNUPG} \
- ftp://ftp.lysator.liu.se/pub/security/%SUBDIR%/
-MASTER_SITE_SUBDIR= lsh lsh/old
+MASTER_SITES= GNU
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Secure (encrypted) remote shell compatible with ssh 2.0
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Secure (encrypted) remote shell compatible with ssh 2
-LIB_DEPENDS= oop:${PORTSDIR}/devel/liboop \
- gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= liboop.so:${PORTSDIR}/devel/liboop \
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libnettle.so:${PORTSDIR}/security/nettle
USE_CSTD= c89
GNU_CONFIGURE= yes
USE_XORG= xau
-USES= gmake
-INSTALL_TARGET= install
-CONFIGURE_ENV= PREFIX="${PREFIX}"
-CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
-CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
-.if defined(WITH_THREADS) || defined(WITH_LSH_THREADS)
-LDFLAGS+= ${PTHREAD_LIBS}
-CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
-.endif
-MAN1= lsftp.1 ssh-conv.1 lshg.1 lsh.1 lsh-writekey.1 lsh-upgrade.1 \
- lsh-upgrade-key.1 lsh-make-seed.1 lsh-keygen.1 \
- lsh-export-key.1 lsh-decrypt-key.1 lsh-decode-key.1 \
- lsh-authorize.1
-MAN5= secsh.5 SPKI.5 SHA.5 DSA.5
-MAN8= sftp-server.8 lshd.8
-INFO= lsh nettle
-
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e "s|M4)|M4) -g|g" ${WRKSRC}/src/nettle/Makefile.in
-
-post-install:
-.for BIN in lsh lsh-keygen lsh-writekey sexp-conv srp-gen lsh-decode-key
- ${STRIP_CMD} ${PREFIX}/bin/${BIN}
-.endfor
-.for SBIN in lshd
- ${STRIP_CMD} ${PREFIX}/sbin/${SBIN}
-.endfor
+USES= gmake shebangfix
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INFO= lsh
+
+SHEBANG_FILES= src/lcp
+
+post-configure:
+ ${REINPLACE_CMD} 's,^#define WITH_READLINE,// &,' \
+ ${WRKSRC}/src/sftp/config.h
test:
(cd ${WRKSRC}/src/testsuite && ${SETENV} ${MAKE_ENV} \
diff --git a/security/lsh/distinfo b/security/lsh/distinfo
index e6ead819a068..8650152770e7 100644
--- a/security/lsh/distinfo
+++ b/security/lsh/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lsh-2.0.4.tar.gz) = 614b9d63e13ad3e162c82b6405d1f67713fc622a8bc11337e72949d613713091
-SIZE (lsh-2.0.4.tar.gz) = 2183843
+SHA256 (lsh-2.1.tar.gz) = 8bbf94b1aa77a02cac1a10350aac599b7aedda61881db16606debeef7ef212e3
+SIZE (lsh-2.1.tar.gz) = 1540150
diff --git a/security/lsh/files/patch-nettle-openssl.c b/security/lsh/files/patch-nettle-openssl.c
deleted file mode 100644
index 9c31a80bda0b..000000000000
--- a/security/lsh/files/patch-nettle-openssl.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/nettle/examples/nettle-openssl.c.orig Thu Aug 10 13:24:43 2006
-+++ src/nettle/examples/nettle-openssl.c Thu Aug 10 13:24:53 2006
-@@ -36,6 +36,7 @@
- #define OPENSSL_DISABLE_OLD_DES_SUPPORT
-
- #include <assert.h>
-+#include <stddef.h>
-
- #include <openssl/aes.h>
- #include <openssl/blowfish.h>
diff --git a/security/lsh/pkg-plist b/security/lsh/pkg-plist
index 20e5fe81185d..b832fe61e08f 100644
--- a/security/lsh/pkg-plist
+++ b/security/lsh/pkg-plist
@@ -11,51 +11,29 @@ bin/lsh-upgrade
bin/lsh-upgrade-key
bin/lsh-writekey
bin/lshg
-bin/nettle-lfib-stream
-bin/pkcs1-conv
-bin/sexp-conv
bin/srp-gen
bin/ssh-conv
-include/nettle/aes.h
-include/nettle/arcfour.h
-include/nettle/arctwo.h
-include/nettle/asn1.h
-include/nettle/base16.h
-include/nettle/base64.h
-include/nettle/bignum.h
-include/nettle/blowfish.h
-include/nettle/buffer.h
-include/nettle/cast128.h
-include/nettle/cbc.h
-include/nettle/ctr.h
-include/nettle/des-compat.h
-include/nettle/des.h
-include/nettle/dsa.h
-include/nettle/hmac.h
-include/nettle/knuth-lfib.h
-include/nettle/macros.h
-include/nettle/md2.h
-include/nettle/md4.h
-include/nettle/md5-compat.h
-include/nettle/md5.h
-include/nettle/memxor.h
-include/nettle/nettle-meta.h
-include/nettle/nettle-stdint.h
-include/nettle/nettle-types.h
-include/nettle/pgp.h
-include/nettle/pkcs1.h
-include/nettle/realloc.h
-include/nettle/rsa-compat.h
-include/nettle/rsa.h
-include/nettle/serpent.h
-include/nettle/sexp.h
-include/nettle/sha.h
-include/nettle/twofish.h
-include/nettle/yarrow.h
-lib/libnettle.a
+man/man1/lsftp.1.gz
+man/man1/lsh-authorize.1.gz
+man/man1/lsh-decode-key.1.gz
+man/man1/lsh-decrypt-key.1.gz
+man/man1/lsh-export-key.1.gz
+man/man1/lsh-keygen.1.gz
+man/man1/lsh-make-seed.1.gz
+man/man1/lsh-upgrade-key.1.gz
+man/man1/lsh-upgrade.1.gz
+man/man1/lsh-writekey.1.gz
+man/man1/lsh.1.gz
+man/man1/lshg.1.gz
+man/man1/ssh-conv.1.gz
+man/man5/DSA.5.gz
+man/man5/SHA.5.gz
+man/man5/SPKI.5.gz
+man/man5/secsh.5.gz
+man/man8/lshd.8.gz
+man/man8/sftp-server.8.gz
sbin/lsh-execuv
%%KRB%%sbin/lsh-krb-checkpw
sbin/lsh-pam-checkpw
sbin/lshd
sbin/sftp-server
-@dirrm include/nettle