aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-07-31 03:10:44 +0800
committerjkim <jkim@FreeBSD.org>2015-07-31 03:10:44 +0800
commita13229db499c524ac7953246316cdaf3d50753f0 (patch)
tree73550c13cd553371250fa4151421eaca31c66d8b /security
parent9dbce374ca868eb9a420bd0bdd5b6c096ff85995 (diff)
downloadfreebsd-ports-gnome-a13229db499c524ac7953246316cdaf3d50753f0.tar.gz
freebsd-ports-gnome-a13229db499c524ac7953246316cdaf3d50753f0.tar.zst
freebsd-ports-gnome-a13229db499c524ac7953246316cdaf3d50753f0.zip
Convert to USES=gssapi.
Diffstat (limited to 'security')
-rw-r--r--security/p5-GSSAPI/Makefile20
-rw-r--r--security/p5-GSSAPI/files/patch-Makefile.PL12
2 files changed, 32 insertions, 0 deletions
diff --git a/security/p5-GSSAPI/Makefile b/security/p5-GSSAPI/Makefile
index 8468c56fe7c3..2ff80d1542a6 100644
--- a/security/p5-GSSAPI/Makefile
+++ b/security/p5-GSSAPI/Makefile
@@ -14,4 +14,24 @@ COMMENT= Perl extension providing access to the GSSAPIv2 library
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFAULT= GSSAPI_BASE
+OPTIONS_SINGLE= GSSAPI
+OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+
+GSSAPI_BASE_USES= gssapi
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_MIT_USES= gssapi:mit
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGSSAPI_MIT}
+KRB5CONF= ${KRB5_HOME}/bin/krb5-config
+.else
+KRB5CONF= ${HEIMDAL_HOME}/bin/krb5-config
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%KRB5CONF%%|${KRB5CONF}|g' \
+ ${WRKSRC}/Makefile.PL
+
.include <bsd.port.mk>
diff --git a/security/p5-GSSAPI/files/patch-Makefile.PL b/security/p5-GSSAPI/files/patch-Makefile.PL
new file mode 100644
index 000000000000..e9664d0bc381
--- /dev/null
+++ b/security/p5-GSSAPI/files/patch-Makefile.PL
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig 2010-04-24 12:37:38 UTC
++++ Makefile.PL
+@@ -12,8 +12,7 @@ my @whichcand = qw(/bin/which /usr/bin/w
+
+ my @KRB5_CONFIG_TRIES = (
+
+- '/usr/kerberos/bin/krb5-config', # for use with CentOS, as suggested by Mark Hedges in https://rt.cpan.org/Ticket/Display.html?id=48732
+- '/usr/bin/krb5-config', # always worth a try ;-)
++ '%%KRB5CONF%%', # for use with FreeBSD
+
+ );
+