aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-26 05:59:37 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-26 05:59:37 +0800
commitbc056b2289f595a9ec91dcf8fab220428c2e4551 (patch)
treee2922e9adf015ba0792ddd4b2551d8663786f91a /security
parentb5e568f5a9d8b69b7e42937c61e932b966621e8f (diff)
downloadfreebsd-ports-gnome-bc056b2289f595a9ec91dcf8fab220428c2e4551.tar.gz
freebsd-ports-gnome-bc056b2289f595a9ec91dcf8fab220428c2e4551.tar.zst
freebsd-ports-gnome-bc056b2289f595a9ec91dcf8fab220428c2e4551.zip
lang/rust: update to 1.30.0
- Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2018/10/25/Rust-1.30.0.html Approved by: rust (tobik) MFH: 2018Q4 (less rust versions to support) Differential Revision: https://reviews.freebsd.org/D17695
Diffstat (limited to 'security')
-rw-r--r--security/cargo-audit/Makefile2
-rw-r--r--security/cargo-audit/files/patch-rust-1.3027
-rw-r--r--security/kr/Makefile2
3 files changed, 29 insertions, 2 deletions
diff --git a/security/cargo-audit/Makefile b/security/cargo-audit/Makefile
index 4a346fcf5592..85caefeb4e2e 100644
--- a/security/cargo-audit/Makefile
+++ b/security/cargo-audit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cargo-audit
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MAINTAINER= tobik@FreeBSD.org
diff --git a/security/cargo-audit/files/patch-rust-1.30 b/security/cargo-audit/files/patch-rust-1.30
new file mode 100644
index 000000000000..a27e1ecced16
--- /dev/null
+++ b/security/cargo-audit/files/patch-rust-1.30
@@ -0,0 +1,27 @@
+https://github.com/RustSec/cargo-audit/commit/1734f5ea4b7a
+
+error: unused `#[macro_use]` import
+ --> src/main.rs:12:1
+ |
+12 | #[macro_use]
+ | ^^^^^^^^^^^^
+ |
+note: lint level defined here
+ --> src/main.rs:5:22
+ |
+5 | #![deny(unsafe_code, warnings, missing_docs, trivial_numeric_casts)]
+ | ^^^^^^^^
+ = note: #[deny(unused_imports)] implied by #[deny(warnings)]
+
+error: aborting due to previous error
+
+--- src/main.rs.orig 2018-07-29 21:14:21 UTC
++++ src/main.rs
+@@ -9,6 +9,7 @@
+ mod shell;
+
+ extern crate gumdrop;
++#[allow(unused_imports)]
+ #[macro_use]
+ extern crate gumdrop_derive;
+ extern crate isatty;
diff --git a/security/kr/Makefile b/security/kr/Makefile
index a1a017d8f9bb..9e585370f6fb 100644
--- a/security/kr/Makefile
+++ b/security/kr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kr
PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MAINTAINER= feld@FreeBSD.org