aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-02-23 21:03:10 +0800
committerdinoex <dinoex@FreeBSD.org>2009-02-23 21:03:10 +0800
commitef6d271a9cbe544dceeb250bac901b49e98c215e (patch)
tree3906a03ffa84652b1b1473d4a9e51f41239cf914 /security
parente15fb2efabac277fbd121b6d1d5acbc5f8d6e137 (diff)
downloadfreebsd-ports-gnome-ef6d271a9cbe544dceeb250bac901b49e98c215e.tar.gz
freebsd-ports-gnome-ef6d271a9cbe544dceeb250bac901b49e98c215e.tar.zst
freebsd-ports-gnome-ef6d271a9cbe544dceeb250bac901b49e98c215e.zip
- fix shared lib path
Force libssl.so to loads the match libcrypto.so. The old fix was not working with 0.9.7 This should help ports linking to openssl from ports in FreeBSD 7.1 and above.
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 30e39a3ed014..9344e878e5fc 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8j
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
@@ -27,10 +28,10 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
EXTRACONFIGURE+= enable-camellia
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
+MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
USE_PERL5_BUILD= yes
-CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 dhparam.1 \
dsa.1 dsaparam.1 ec.1 ecparam.1 enc.1 errstr.1 gendsa.1 genrsa.1 \