aboutsummaryrefslogtreecommitdiffstats
path: root/shells/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-16 17:02:00 +0800
committerknu <knu@FreeBSD.org>2001-03-16 17:02:00 +0800
commitbe5ab08403084f57246a3a4913789caa5fa4190b (patch)
treeca8d0d630ce086c8a5e187c4df76e21211755485 /shells/Makefile
parentf107c63dbec399d203fd163b3ddaba92d50a8f6f (diff)
downloadfreebsd-ports-gnome-be5ab08403084f57246a3a4913789caa5fa4190b.tar.gz
freebsd-ports-gnome-be5ab08403084f57246a3a4913789caa5fa4190b.tar.zst
freebsd-ports-gnome-be5ab08403084f57246a3a4913789caa5fa4190b.zip
Add ruby-shell, a Ruby library to run commands and control jobs like a
shell. Pipes and redirections work just as expected: sh = Shell.cd("/foo") sh.cat("bar") | sh.tee("baz") > "baa" # or sh.transact do cat("bar") | tee("baz") > "baa" end
Diffstat (limited to 'shells/Makefile')
-rw-r--r--shells/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index a9eeb1f2fd97..acdd23eb6f55 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -14,6 +14,7 @@
SUBDIR += pdksh
SUBDIR += perlsh
SUBDIR += rc
+ SUBDIR += ruby-shell
SUBDIR += sash
SUBDIR += scsh
SUBDIR += tcsh