aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash-completion/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-12-21 04:00:54 +0800
committeradamw <adamw@FreeBSD.org>2013-12-21 04:00:54 +0800
commit6311b771e4cf3962bb517196db583ee1d9c6d081 (patch)
tree0cbc8a6897a236501851ac3ab6ccb150c7626a04 /shells/bash-completion/Makefile
parent8233135cd006693b28ce02204ddf854ee6041411 (diff)
downloadfreebsd-ports-gnome-6311b771e4cf3962bb517196db583ee1d9c6d081.tar.gz
freebsd-ports-gnome-6311b771e4cf3962bb517196db583ee1d9c6d081.tar.zst
freebsd-ports-gnome-6311b771e4cf3962bb517196db583ee1d9c6d081.zip
Fix staging as non-root.
Submitted by: Anton Yuzhaninov <citrin@citrin.ru> While I'm here, convert bash selection to OPTIONS.
Diffstat (limited to 'shells/bash-completion/Makefile')
-rw-r--r--shells/bash-completion/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 565bcbe7b166..ed40ff6ec688 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -10,14 +10,12 @@ MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
-.if defined(WITH_BASH_DEVEL)
-RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
-.else
-RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
-.endif
+OPTIONS_DEFINE= BASH_DEVEL
+BASH_DEVEL_DESC= Use shells/bash-devel instead of shells/bash
CONFLICTS= bash-completion-classic-[0-9]*
+USE_AUTOTOOLS= aclocal automake
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,7 +24,15 @@ USE_BZIP2= yes
SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
-post-patch:
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBASH_DEVEL}
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
+.else
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
+.endif
+
+post-configure:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \