aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash-completion
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-01-06 22:53:34 +0800
committeradamw <adamw@FreeBSD.org>2014-01-06 22:53:34 +0800
commit1a6110fd67d454162a2eb3e78a5ceaa5feb9b261 (patch)
treeda66ede07309dd89a4239358705e18f90b265649 /shells/bash-completion
parentb079a0f070d0d58176ea88bdfc8553c9a7b12e32 (diff)
downloadfreebsd-ports-gnome-1a6110fd67d454162a2eb3e78a5ceaa5feb9b261.tar.gz
freebsd-ports-gnome-1a6110fd67d454162a2eb3e78a5ceaa5feb9b261.tar.zst
freebsd-ports-gnome-1a6110fd67d454162a2eb3e78a5ceaa5feb9b261.zip
Host the bash-completion-2.1 distfile on MASTER_SITE_LOCAL.
I really have no idea what is going on with the distfile. The 2.1 tag has been in the b-c git tree for 9 months now, but their website hasn't been updated to reflect this. Their alioth area now shows no files whatsoever, which makes this version (and any other) unfetchable. Some distros are also using 2.1, some aren't. So, let's cut our losses and just host it ourselves. Hopefully this can help some other distros too. While I'm here, clean up the Makefile a bit to feed my OCD.
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 39531cfe6462..e44c079403ac 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -1,12 +1,13 @@
# Created by: kirk@strauser.com
# $FreeBSD$
-PORTNAME= bash-completion
+PORTNAME= bash-completion
PORTVERSION= 2.1
PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= shells
-MASTER_SITES= http://bash-completion.alioth.debian.org/files/
+PORTEPOCH= 1
+CATEGORIES= shells
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= adamw
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
@@ -16,11 +17,10 @@ BASH_DEVEL_DESC= Use shells/bash-devel instead of shells/bash
CONFLICTS= bash-completion-classic-[0-9]*
+USE_BZIP2= yes
USE_AUTOTOOLS= aclocal automake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
-USE_BZIP2= yes
+USES= gmake
SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
@@ -48,9 +48,9 @@ post-configure:
${WRKSRC}/completions/*
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for i in README doc/bash_completion.txt doc/bashrc doc/inputrc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in README doc/bash_completion.txt doc/bashrc doc/inputrc
${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}${DOCSDIR}
-. endfor
+.endfor
.include <bsd.port.mk>