aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-03-25 05:10:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-03-25 05:10:54 +0800
commit835b7dfb0320f83c1d6d39a2f42d68600fcae9ec (patch)
treef7e7e26fbeaed5374734eb72b5f871ae7dba1c36 /shells/bash-completion
parentb810f6b6b8cf81d178c12e7d55120fac03da9396 (diff)
downloadfreebsd-ports-gnome-835b7dfb0320f83c1d6d39a2f42d68600fcae9ec.tar.gz
freebsd-ports-gnome-835b7dfb0320f83c1d6d39a2f42d68600fcae9ec.tar.zst
freebsd-ports-gnome-835b7dfb0320f83c1d6d39a2f42d68600fcae9ec.zip
Support bash-static users
- Add BASH_SHARED and BASH_STATIC options Requested by: Melissa Pilgrim <heliosyne@gmail.com>
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 24092c1df241..3fdb44b37a48 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -15,11 +15,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to build: gmake: install-recursive: Error 1
BROKEN_armv7= fails to build: gmake: install-recursive: Error 1
-RUN_DEPENDS= bash:shells/bash
-
OPTIONS_DEFINE= CMAKE_MODULES DOCS
-OPTIONS_DEFAULT=CMAKE_MODULES
+OPTIONS_SINGLE= BASH
+OPTIONS_SINGLE_BASH= BASH_SHARED BASH_STATIC
+OPTIONS_DEFAULT=BASH_SHARED CMAKE_MODULES
OPTIONS_SUB= yes
+BASH_SHARED_DESC= Use shells/bash as backend
+BASH_STATIC_DESC= Use shells/bash-static as backend
CMAKE_MODULES_DESC= Install bash-completion modules for cmake
NO_ARCH= yes
@@ -32,6 +34,9 @@ SUB_LIST= RUNFILE=${DATADIR}/bash_completion.sh
GH_ACCOUNT= scop
USE_GITHUB= yes
+BASH_SHARED_RUN_DEPENDS=bash:shells/bash
+BASH_STATIC_RUN_DEPENDS=bash:shells/bash-static
+
post-patch:
@${REINPLACE_CMD} \
-e '/^profiledir =/ s|(sysconfdir)/profile.d|(prefix)/share/bash-completion|' \