aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash-devel/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-11-01 18:29:18 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-11-01 18:29:18 +0800
commitb58758509eaca9ac7d51378a9e4e7a69b6e57d20 (patch)
treeb3fd24084fc628b8d4ca187997ea2eb08bc36f6b /shells/bash-devel/Makefile
parent048eddf864824257e2b6df2cd73f2cc2730930ee (diff)
downloadfreebsd-ports-gnome-b58758509eaca9ac7d51378a9e4e7a69b6e57d20.tar.gz
freebsd-ports-gnome-b58758509eaca9ac7d51378a9e4e7a69b6e57d20.tar.zst
freebsd-ports-gnome-b58758509eaca9ac7d51378a9e4e7a69b6e57d20.zip
Support staging.
Diffstat (limited to 'shells/bash-devel/Makefile')
-rw-r--r--shells/bash-devel/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/shells/bash-devel/Makefile b/shells/bash-devel/Makefile
index 4284fba32f8e..79bfe1053a2d 100644
--- a/shells/bash-devel/Makefile
+++ b/shells/bash-devel/Makefile
@@ -33,7 +33,6 @@ HELP_DESC= Enable builtin help
USES= bison
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPLICITCD}
@@ -44,7 +43,6 @@ EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-implicitcd
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-colonbreakswords
.endif
-MAN1= bash.1 bashbug.1
INFO= bash
MAKE_JOBS_UNSAFE= yes
@@ -107,22 +105,16 @@ post-configure:
pre-build:
@${ECHO_CMD} $$((${PORTREVISION}-1)) > ${WRKSRC}/.build
-pre-install:
- @${SETENV} PKG_PREFIX="${PREFIX}" \
- ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
- @cd ${PREFIX}/bin ; ${LN} -sf bash rbash
+ @cd ${STAGEDIR}${PREFIX}/bin ; ${LN} -sf bash rbash
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/FAQ \
- ${WRKSRC}/doc/INTRO ${DOCSDIR}
+ ${WRKSRC}/doc/INTRO ${STAGEDIR}${DOCSDIR}
@for d in ${PORTDOCS:NFAQ:NINTRO}; do \
- ${INSTALL_DATA} ${WRKSRC}/$${d} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/$${d} ${STAGEDIR}${DOCSDIR}; \
done
.endif
- @${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
regress: build
cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
@@ -130,6 +122,7 @@ regress: build
ckp:
${MAKE} -DPATCH_DEBUG clean patch
+# requires ftp/ncftp3
cklatest:
@${ECHO} -n "Currently at: "
@${MAKE} -V PATCHLEVEL