aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2010-09-10 10:30:50 +0800
committerobrien <obrien@FreeBSD.org>2010-09-10 10:30:50 +0800
commitbf7d49b5ed4dd8f96317c840449aac0680df2551 (patch)
treee6e0d9361a110123d50c8d37e7bac5a29efdc361 /shells/bash/Makefile
parent9b7ee9d986d20041c3fa5c3290fc66de57e9de78 (diff)
downloadfreebsd-ports-gnome-bf7d49b5ed4dd8f96317c840449aac0680df2551.tar.gz
freebsd-ports-gnome-bf7d49b5ed4dd8f96317c840449aac0680df2551.tar.zst
freebsd-ports-gnome-bf7d49b5ed4dd8f96317c840449aac0680df2551.zip
Add OPTIONS processing.
Diffstat (limited to 'shells/bash/Makefile')
-rw-r--r--shells/bash/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 79351c9d7634..77a527e92ce8 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -31,6 +31,12 @@ COMMENT= The GNU Project's Bourne Again SHell
IGNOREFILES= FAQ
+.if defined(WITH_OPTIONS) || defined(WITH_BASH_OPTIONS)
+.include "${.CURDIR}/../bash/options"
+.endif
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_IMPLICITCD)
EXTRA_PATCHES+= ${PATCHDIR}/xpatch-implicitcd
.endif
@@ -96,8 +102,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
YACC="bison -y"
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
.if defined(WITHOUT_NLS)