aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash/Makefile
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-10-09 18:16:33 +0800
committereik <eik@FreeBSD.org>2004-10-09 18:16:33 +0800
commit1d7281f7a1f6ed33d3665fc3b662fd0ea695b5f0 (patch)
tree6ad145ab4cd1b552938eafcbfc92a7b4645075a1 /shells/bash/Makefile
parent5ead3ea08c4e3c104e61010b10fbfbf07e9a9640 (diff)
downloadfreebsd-ports-gnome-1d7281f7a1f6ed33d3665fc3b662fd0ea695b5f0.tar.gz
freebsd-ports-gnome-1d7281f7a1f6ed33d3665fc3b662fd0ea695b5f0.tar.zst
freebsd-ports-gnome-1d7281f7a1f6ed33d3665fc3b662fd0ea695b5f0.zip
Fix process substitution on systems without fdescfs (FreeBSD 5.x, 6.x)
While I'm here, use the official patchset instead of the custom ones and reflect the port revision in the version number. Submitted by: Reinhard Speyerer <rspmn@arcor.de> Approved by: portmgr (krion)
Diffstat (limited to 'shells/bash/Makefile')
-rw-r--r--shells/bash/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 63b7619a537b..c9a8999410d9 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bash
PORTVERSION= 3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
http://cnswww.cns.cwru.edu/~chet/%SUBDIR%/:faq \
@@ -17,6 +17,12 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:bash
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+PATCH_SITES= ftp://ftp.cwru.edu/pub/%SUBDIR%/:bash
+PATCH_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}-patches/:bash
+.for patch in 01 02 03 04 05 06 07 08 09 10 11 12 13
+PATCHFILES+= ${PORTNAME}${PORTVERSION:S/.//g}-0${patch}:bash
+.endfor
+
MAINTAINER= eik@FreeBSD.org
COMMENT= The GNU Project's Bourne Again SHell
@@ -72,6 +78,9 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
post-patch:
@${REINPLACE_CMD} -e "s| /bin| ${PREFIX}/bin|g" ${WRKSRC}/doc/bash.1
+pre-build:
+ @${ECHO_CMD} $$((${PORTREVISION}-1)) > ${WRKSRC}/.build
+
pre-install:
@${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL; \