aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash2/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-08 19:44:12 +0800
committervs <vs@FreeBSD.org>2004-07-08 19:44:12 +0800
commit2f645c5980fc6234e19dcab11fa1510e679149d1 (patch)
treef85d3cf799c4e0e9545023ec35692c67e1ada98f /shells/bash2/Makefile
parenta7cea8f236e8e5398bd3eeb0315cb3b91930a4d5 (diff)
downloadfreebsd-ports-gnome-2f645c5980fc6234e19dcab11fa1510e679149d1.tar.gz
freebsd-ports-gnome-2f645c5980fc6234e19dcab11fa1510e679149d1.tar.zst
freebsd-ports-gnome-2f645c5980fc6234e19dcab11fa1510e679149d1.zip
Fix location of binary in man-page
PR: ports/42729 Submitted by: Harold Gutch Approved by: maintainer timeout
Diffstat (limited to 'shells/bash2/Makefile')
-rw-r--r--shells/bash2/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index e4a986b630ef..0f3fe1dcbf51 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -31,6 +31,7 @@ COMMENT= The GNU Bourne Again Shell
.include <bsd.port.pre.mk>
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
@@ -41,6 +42,10 @@ CONFIGURE_ARGS+= --enable-static-link=no
.endif
MAN1= bash.1 bashbug.1
+post-patch:
+ @${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
+ ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
+
post-install:
${CP} /etc/shells /etc/shells.bak
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells