aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-10-29 19:37:06 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-10-29 19:37:06 +0800
commit0ef5a217bf1be953ff07a66a9b347c6987cde63e (patch)
treea926f249d351188aac0e15748ef814bb7feafa77 /shells/bash
parent82c0796f4f570efa1caf29670f90718ffea7639a (diff)
downloadfreebsd-ports-gnome-0ef5a217bf1be953ff07a66a9b347c6987cde63e.tar.gz
freebsd-ports-gnome-0ef5a217bf1be953ff07a66a9b347c6987cde63e.tar.zst
freebsd-ports-gnome-0ef5a217bf1be953ff07a66a9b347c6987cde63e.zip
Provide an option to enable system-wide rc files.
This enables: - System-wide .bashrc file for interactive shells ${PREFIX}/etc/bash.bashrc - System-wide .bash_logout for login shells ${PREFIX}/etc/bash.bash_logout PR: 222973 Submitted by: ilyushkeane@gmail.com
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index e7f2d40cb0b5..37f58e8302c8 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 12
PORTVERSION= 4.4.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -22,10 +22,11 @@ COMMENT= GNU Project's Bourne Again SHell
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= COLONBREAKSWORDS FDESCFS HELP NLS STATIC SYSLOG DOCS
+OPTIONS_DEFINE= COLONBREAKSWORDS FDESCFS HELP NLS STATIC SYSBASHRC SYSLOG DOCS
COLONBREAKSWORDS_DESC= Colons break words
FDESCFS_DESC= Enable use of /dev/fd
HELP_DESC= Enable builtin help
+SYSBASHRC_DESC= Enable system-wide rc files
OPTIONS_DEFAULT= COLONBREAKSWORDS HELP
@@ -84,6 +85,11 @@ post-patch:
${WRKSRC}/config-top.h
.endif
+post-patch-SYSBASHRC-on:
+ @${REINPLACE_CMD} \
+ -e "s|.*\(#define SYS_BASH.*\)\(/etc/.*\"\).*|\1${PREFIX}\2|" \
+ ${WRKSRC}/config-top.h
+
post-configure:
@${FIND} ${WRKSRC} -name Makefile -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|"