aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2009-03-13 23:54:23 +0800
committerobrien <obrien@FreeBSD.org>2009-03-13 23:54:23 +0800
commit2d532d59840c323f0cae70801f676ebde9abe117 (patch)
tree184ed965151b347b7f4af028084132a5f6b37e70 /shells/bash
parentcf67dea8f1046012dc1f12c8d203c894ab49afe5 (diff)
downloadfreebsd-ports-gnome-2d532d59840c323f0cae70801f676ebde9abe117.tar.gz
freebsd-ports-gnome-2d532d59840c323f0cae70801f676ebde9abe117.tar.zst
freebsd-ports-gnome-2d532d59840c323f0cae70801f676ebde9abe117.zip
Use Bison in the build instead of byacc.
This fixes the issue of '$()' (for ``) not being parsed correctly. PR: 101230 Submitted by: bf2006a@yahoo.com
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index e556f567fc76..8efdae7eb3d0 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -9,7 +9,7 @@
PORTNAME= bash
PATCHLEVEL= 10
PORTVERSION= 4.0.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/:faq
@@ -44,6 +44,7 @@ MAN1= bash.1 bashbug.1
INFO= bash
GNU_CONFIGURE= yes
+USE_BISON= build
.if !defined(NOPORTDOCS)
.if !defined(WITH_INCLUDED_FAQ)
@@ -92,7 +93,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- YACC="${YACC}"
+ YACC="bison"
.include <bsd.port.pre.mk>
@@ -128,6 +129,9 @@ post-install:
@${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+regress: build
+ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
+
cklatest:
-ncftpls \
ftp://ftp.cwru.edu/pub/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/\.[0-9a-z]*$//}-patches/ \