aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-11-02 18:24:50 +0800
committereik <eik@FreeBSD.org>2004-11-02 18:24:50 +0800
commit894962b48c089f91d41a8d20da33097d730012b5 (patch)
treeeb9586f3b36eb6acffd8971346bd53d2514b64bf /shells/bash
parentb6d21c13d12dc8b09ca20b7a6de8d7f700d31dde (diff)
downloadfreebsd-ports-gnome-894962b48c089f91d41a8d20da33097d730012b5.tar.gz
freebsd-ports-gnome-894962b48c089f91d41a8d20da33097d730012b5.tar.zst
freebsd-ports-gnome-894962b48c089f91d41a8d20da33097d730012b5.zip
- update to patchlevel 15
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/bash/distinfo4
-rw-r--r--shells/bash/files/patch-braces.c17
3 files changed, 7 insertions, 19 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index ca12271e168d..56ae9d2cda35 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bash
-PORTVERSION= 3.0.13
+PORTVERSION= 3.0.${PATCHLEVEL}
PORTREVISION= 0
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
@@ -20,8 +20,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= ftp://ftp.cwru.edu/pub/%SUBDIR%/:bash
PATCH_SITE_SUBDIR= ${PORTNAME}/${DISTNAME}-patches/:bash
-.for patch in 01 02 03 04 05 06 07 08 09 10 11 12 13
+.for patch in 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15
PATCHFILES+= ${PORTNAME}${PORTVERSION:R:S/.//g}-0${patch}:bash
+PATCHLEVEL= ${patch}
.endfor
MAINTAINER= eik@FreeBSD.org
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
index 12a751b3f1d5..c00b548eb2b9 100644
--- a/shells/bash/distinfo
+++ b/shells/bash/distinfo
@@ -26,4 +26,8 @@ MD5 (bash/bash30-012) = 2753d4de0b57fc8890488463c5e86d3f
SIZE (bash/bash30-012) = 1395
MD5 (bash/bash30-013) = 5de5be8289764c11a3206b06351d81a6
SIZE (bash/bash30-013) = 1963
+MD5 (bash/bash30-014) = d4b531e02b6a0287cffdbf527134ca29
+SIZE (bash/bash30-014) = 1165
+MD5 (bash/bash30-015) = adc1ab952b42ed0c0f53d1c308a32101
+SIZE (bash/bash30-015) = 1480
MD5 (bash/FAQ) = IGNORE
diff --git a/shells/bash/files/patch-braces.c b/shells/bash/files/patch-braces.c
deleted file mode 100644
index 49cf804cc39f..000000000000
--- a/shells/bash/files/patch-braces.c
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Fix brace expansion following quoted text
-#
-# http://lists.gnu.org/archive/html/bug-bash/2004-09/msg00255.html
-#
---- braces.c.orig Wed Sep 8 11:07:53 2004
-+++ braces.c Fri Sep 17 18:42:36 2004
-@@ -402,7 +402,8 @@
- {
- pass_next = 1;
- i++;
-- level++;
-+ if (quoted == 0)
-+ level++;
- continue;
- }
- #endif