aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-11-03 02:28:59 +0800
committernaddy <naddy@FreeBSD.org>2009-11-03 02:28:59 +0800
commitd437ee7ded4974535c141f847c80693d04f4c3f2 (patch)
tree59427f7ab3344c0eabe7559f6071e49d9373fea8 /shells/bash
parent17203713f39cd4b4994d27ceebd83fb5ca92cb0c (diff)
downloadfreebsd-ports-gnome-d437ee7ded4974535c141f847c80693d04f4c3f2.tar.gz
freebsd-ports-gnome-d437ee7ded4974535c141f847c80693d04f4c3f2.tar.zst
freebsd-ports-gnome-d437ee7ded4974535c141f847c80693d04f4c3f2.zip
Pass the -y flag to bison to fix $() parsing.
Plain "bison -d parse.y" outputs parse.tab.c instead of y.tab.c, so y.tab.c is never regenerated, and the parser fix from patch 001 is effectively not applied. PR: 139720 Approved by: maintainer timeout (4+2 weeks)
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 1e0656653e64..86b1661a9053 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -9,7 +9,7 @@
PORTNAME= bash
PATCHLEVEL= 33
PORTVERSION= 4.0.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/:faq
@@ -93,7 +93,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- YACC="bison"
+ YACC="bison -y"
.include <bsd.port.pre.mk>