aboutsummaryrefslogtreecommitdiffstats
path: root/shells/fd
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /shells/fd
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'shells/fd')
-rw-r--r--shells/fd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 6a29cda473e4..2642ca39e2d4 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -11,7 +11,7 @@ DISTNAME= FD-${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
COMMENT= CUI-based file and directory management tool
-MAKE_ENV= LANG=ja
+USE_LOCALE= ja
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
PREFIX="\$$(DESTDIR)${PREFIX}" \
CONFDIR="\$$(DESTDIR)${PREFIX}/etc" \