aboutsummaryrefslogtreecommitdiffstats
path: root/shells/fd
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2010-06-07 10:22:59 +0800
committerknu <knu@FreeBSD.org>2010-06-07 10:22:59 +0800
commitbdae8847b6f4a1b1e1474f46235395b4187d352e (patch)
treee50be7831abfc8ae94408d5ecee71edfb7273774 /shells/fd
parent3af1d3b1ec507f5927f81347c0e632ed57d03d70 (diff)
downloadfreebsd-ports-gnome-bdae8847b6f4a1b1e1474f46235395b4187d352e.tar.gz
freebsd-ports-gnome-bdae8847b6f4a1b1e1474f46235395b4187d352e.tar.zst
freebsd-ports-gnome-bdae8847b6f4a1b1e1474f46235395b4187d352e.zip
Apply a quick-fix against the problem introduced in 3.00g.
Diffstat (limited to 'shells/fd')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-parse.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 00d5df933f4d..c77489d0172e 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 3.00g
+PORTREVISION= 1
CATEGORIES= shells net
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/files/patch-parse.c b/shells/fd/files/patch-parse.c
new file mode 100644
index 000000000000..f4a15cd2d306
--- /dev/null
+++ b/shells/fd/files/patch-parse.c
@@ -0,0 +1,14 @@
+Patch by Rikito INAKAZU [FDclone-users:00861]
+
+diff -u parse.c.orig parse.c
+--- parse.c.orig 2010-06-04 00:00:00.000000000 +0900
++++ parse.c 2010-06-05 22:16:04.000000000 +0900
+@@ -831,7 +831,7 @@
+ while (*cp) {
+ *bufp = c_realloc(*bufp, j + MAXCHARWID - 1, &size);
+ if (unprint) {
+- (*bufp)[j] = *cp;
++ (*bufp)[j++] = *cp++;
+ continue;
+ }
+