aboutsummaryrefslogtreecommitdiffstats
path: root/shells/fish
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-04-18 21:20:52 +0800
committerkoobs <koobs@FreeBSD.org>2015-04-18 21:20:52 +0800
commitc4494e0a604bfe5ad12b1452d5637026f4f48520 (patch)
treebc73857d005d9ce3437359ec21e017db479d580a /shells/fish
parentd40453cba9bc86d2a6367cebe6d1f030b4b29537 (diff)
downloadfreebsd-ports-gnome-c4494e0a604bfe5ad12b1452d5637026f4f48520.tar.gz
freebsd-ports-gnome-c4494e0a604bfe5ad12b1452d5637026f4f48520.tar.zst
freebsd-ports-gnome-c4494e0a604bfe5ad12b1452d5637026f4f48520.zip
shells/fish: Fix for hangs on FreeBSD 10.1+
Fix for hangs on FreeBSD 10.1+ due to WCHAR_T missing as an alias for UCS-4-INTERNAL. [1] https://github.com/fish-shell/fish-shell/issues/1741 PR: 196661 Submitted by: David Adam <zanchey ucc.gu.uwa.edu.au> Approved by: maintainer <freebsd.users gmail com>
Diffstat (limited to 'shells/fish')
-rw-r--r--shells/fish/Makefile2
-rw-r--r--shells/fish/files/patch-env__universal__common.cpp14
2 files changed, 15 insertions, 1 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index cf51f40db523..6b2813488496 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fish
PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
diff --git a/shells/fish/files/patch-env__universal__common.cpp b/shells/fish/files/patch-env__universal__common.cpp
new file mode 100644
index 000000000000..741cbec49468
--- /dev/null
+++ b/shells/fish/files/patch-env__universal__common.cpp
@@ -0,0 +1,14 @@
+# Description: Hangs on freebsd when starting shell
+# Issue ID: https://github.com/fish-shell/fish-shell/issues/1741
+# TODO: Remove after 2.1.2 update
+
+--- env_universal_common.cpp.orig 2015-04-18 11:58:07 UTC
++++ env_universal_common.cpp
+@@ -151,6 +151,7 @@ static const char *iconv_wide_names_4[]=
+ {
+ "wchar_t", "WCHAR_T",
+ "wchar", "WCHAR",
++ "UCS-4-INTERNAL",
+ "ucs-4", "UCS-4",
+ "ucs4", "UCS4",
+ "utf-32", "UTF-32",