aboutsummaryrefslogtreecommitdiffstats
path: root/shells/mudsh/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-03-01 23:57:14 +0800
committerclive <clive@FreeBSD.org>2001-03-01 23:57:14 +0800
commita0870fdead7b76864610094b5563310eddea8cea (patch)
tree320399ec493c679b662210f3d6511f8d3f792b19 /shells/mudsh/Makefile
parent4d0de06f2547821f728e3ce1558deeb1a1d9dccc (diff)
downloadfreebsd-ports-gnome-a0870fdead7b76864610094b5563310eddea8cea.tar.gz
freebsd-ports-gnome-a0870fdead7b76864610094b5563310eddea8cea.tar.zst
freebsd-ports-gnome-a0870fdead7b76864610094b5563310eddea8cea.zip
New port: mudsh: An "intelligent" game-like shell
PR: ports/25441 Submitted by: George Reid <greid@dogma.freebsd-uk.eu.org>
Diffstat (limited to 'shells/mudsh/Makefile')
-rw-r--r--shells/mudsh/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/shells/mudsh/Makefile b/shells/mudsh/Makefile
new file mode 100644
index 000000000000..c17a310ccf8d
--- /dev/null
+++ b/shells/mudsh/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mudsh
+# Date created: 28 February 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mudsh
+PORTVERSION= 20010228
+CATEGORIES= shells
+MASTER_SITES= http://www.xirium.com/tech/mud-shell/download/
+DISTNAME= mudsh
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+NO_WRKSUBDIR= yes
+
+NO_BUILD= yes
+
+post-extract:
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-patch:
+ @(${SED} -e 's,/usr/local/bin/perl,${PERL},1' ${WRKSRC}/${DISTNAME} \
+ > foo && ${MV} foo ${WRKSRC}/${DISTNAME})
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/mudsh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/mudsh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>