aboutsummaryrefslogtreecommitdiffstats
path: root/shells/osh/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-30 09:31:08 +0800
committerwill <will@FreeBSD.org>2000-12-30 09:31:08 +0800
commitd1e264ab741debad23415fa7f416f3d56e803b05 (patch)
tree7c61e18ae8e5811430ed912d87234fcf387ce2cf /shells/osh/Makefile
parent3db5d629851671adb6f351bb6c04bce035643534 (diff)
downloadfreebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.tar.gz
freebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.tar.zst
freebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.zip
Add osh 001127, a reimplementation of the old and obsolete shell version
that was in standard use up to UNIX 6th Edition and was supplied as osh with UNIX 7th Edition. Its command language is a sparse subset of those of modern shells and is mostly common to both sh(1) and csh(1). PR: 23943 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'shells/osh/Makefile')
-rw-r--r--shells/osh/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
new file mode 100644
index 000000000000..59531ba59338
--- /dev/null
+++ b/shells/osh/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: osh
+# Date created: 29 December 2000
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osh
+PORTVERSION= 001127
+CATEGORIES= shells
+MASTER_SITES= http://omnibus.ruf.uni-freiburg.de/~gritter/archive/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+MAKEFILE= makefile
+
+MAN1= osh.1
+
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/osh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/osh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>