aboutsummaryrefslogtreecommitdiffstats
path: root/shells/perlsh/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-05-04 13:47:17 +0800
committerclsung <clsung@FreeBSD.org>2005-05-04 13:47:17 +0800
commitb335eb28da42e263b9b0f39f6e8441404475bc96 (patch)
treeb12f72e241526e505e5755a69ad974136b8035a3 /shells/perlsh/Makefile
parent31667514e2d238154147b200a6583b5a6f1f3160 (diff)
downloadfreebsd-ports-gnome-b335eb28da42e263b9b0f39f6e8441404475bc96.tar.gz
freebsd-ports-gnome-b335eb28da42e263b9b0f39f6e8441404475bc96.tar.zst
freebsd-ports-gnome-b335eb28da42e263b9b0f39f6e8441404475bc96.zip
- Change the way used to add/remove the shell on /etc/shells,
use pkg-install and pkg-deinstall (both stoled from shells/bash) to do it. - Remove pre-install section, it's not more needed on this version, because Makefile is created correctly changing Makefile.PL PR: 80583 Submitted by: Renato Botelho (maintainer)
Diffstat (limited to 'shells/perlsh/Makefile')
-rw-r--r--shells/perlsh/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/shells/perlsh/Makefile b/shells/perlsh/Makefile
index a63de2eb5545..aa9b46da987e 100644
--- a/shells/perlsh/Makefile
+++ b/shells/perlsh/Makefile
@@ -29,16 +29,7 @@ MAN3= Psh::Completion.3 \
Psh::Strategy.3 \
Psh::StrategyBunch.3
-pre-install:
- @${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
- @${PERL} -pi -e "s:/usr/local/man/man1:${MAN3PREFIX}/man/man1:g" ${WRKSRC}/Makefile;
- @${PERL} -pi -e "s:/usr/local/lib/perl5/5.00503/man/man3:${MAN3PREFIX}/man/man3:g" ${WRKSRC}/Makefile;
-
post-install:
- @${ECHO_MSG} "Updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @(${GREP} -v ${PREFIX}/bin/psh /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/psh) > /etc/shells
- @${RM} /etc/shells.bak
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>