aboutsummaryrefslogtreecommitdiffstats
path: root/shells/psh
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-06-24 04:29:01 +0800
committerpat <pat@FreeBSD.org>2002-06-24 04:29:01 +0800
commitcf6da9c2084f076043b607e9aa6cabfe42da0fa9 (patch)
tree370fcbb6d6f08270d45d4568848a36e376726f0f /shells/psh
parent9ceaffbf4dbb65eaf9582a23b08e02bc97f57287 (diff)
downloadfreebsd-ports-gnome-cf6da9c2084f076043b607e9aa6cabfe42da0fa9.tar.gz
freebsd-ports-gnome-cf6da9c2084f076043b607e9aa6cabfe42da0fa9.tar.zst
freebsd-ports-gnome-cf6da9c2084f076043b607e9aa6cabfe42da0fa9.zip
PERL -> REINPLACE_CMD
PR: ports/39731, ports/39732, ports/39733, ports/39734, ports/39735 ports/39736, ports/39737, ports/39738, ports/39739 ports/39740 Submitted by: Scott Flatman <sf@dsinw.com>
Diffstat (limited to 'shells/psh')
-rw-r--r--shells/psh/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/shells/psh/Makefile b/shells/psh/Makefile
index 1138c9ec4c3e..67e24ce4c4e9 100644
--- a/shells/psh/Makefile
+++ b/shells/psh/Makefile
@@ -15,6 +15,7 @@ DISTNAME= psh-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
PERL_CONFIGURE= yes
+USE_REINPLACE= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Psh::Builtins.3 \
@@ -38,9 +39,9 @@ MAN3= Psh::Builtins.3 \
Psh::Util.3
pre-install:
- ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
- ${PERL} -pi -e "s:/usr/local/man/man1:${MAN3PREFIX}/man/man1:g" ${WRKSRC}/Makefile;
- ${PERL} -pi -e "s:/usr/local/lib/perl5/5.00503/man/man3:${MAN3PREFIX}/man/man3:g" ${WRKSRC}/Makefile;
+ ${REINPLACE_CMD} -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
+ ${REINPLACE_CMD} -e "s:/usr/local/man/man1:${MAN3PREFIX}/man/man1:g" ${WRKSRC}/Makefile;
+ ${REINPLACE_CMD} -e "s:/usr/local/lib/perl5/5.00503/man/man3:${MAN3PREFIX}/man/man3:g" ${WRKSRC}/Makefile;
post-install:
@${ECHO} "Updating /etc/shells"