aboutsummaryrefslogtreecommitdiffstats
path: root/shells/sash/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-01-30 06:36:06 +0800
committersteve <steve@FreeBSD.org>2000-01-30 06:36:06 +0800
commit6877e02cdad2cbac48f0f8fb320c8f21fc3437d7 (patch)
treeb4ad3a053563553333593ef6589c7d38e64132f4 /shells/sash/Makefile
parentaaf21feb804cd4a3b07f655ed88e6600a7144b6f (diff)
downloadfreebsd-ports-gnome-6877e02cdad2cbac48f0f8fb320c8f21fc3437d7.tar.gz
freebsd-ports-gnome-6877e02cdad2cbac48f0f8fb320c8f21fc3437d7.tar.zst
freebsd-ports-gnome-6877e02cdad2cbac48f0f8fb320c8f21fc3437d7.zip
Adding sash version 3.4.
A Stand-Alone shell combining many common utilities. PR: 16309 Submitted by: Patrick Gardella <patrick@freebsd.org>
Diffstat (limited to 'shells/sash/Makefile')
-rw-r--r--shells/sash/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/shells/sash/Makefile b/shells/sash/Makefile
new file mode 100644
index 000000000000..1945c773ede6
--- /dev/null
+++ b/shells/sash/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sash
+# Version required: 3.4
+# Date created: Jan 22, 2000
+# Whom: Patrick Gardella <patrick@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= sash-3.4
+CATEGORIES= shells
+MASTER_SITES= http://www.pcug.org.au/~dbell/programs/ \
+ http://www.freebsd.org/~patrick/
+
+MAINTAINER= patrick@freebsd.org
+
+MAN1= sash.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sash ${PREFIX}/bin/sash
+ ${INSTALL_MAN} ${WRKSRC}/sash.1 ${PREFIX}/man/man1/sash.1
+ @${ECHO_MSG} "------------------"
+ @${ECHO_MSG} "Installing into ${PREFIX}/bin"
+ @${ECHO_MSG} "If you want this installed elsewhere, "
+ @${ECHO_MSG} "set the environmental variable PREFIX"
+ @${ECHO_MSG} "------------------"
+
+post-install:
+ @${ECHO_MSG} "Updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/sash /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/sash) > /etc/shells
+ @${RM} /etc/shells.bak
+ strip ${PREFIX}/bin/sash
+
+.include <bsd.port.mk>