aboutsummaryrefslogtreecommitdiffstats
path: root/shells/v7sh/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-22 16:24:19 +0800
committerpav <pav@FreeBSD.org>2004-06-22 16:24:19 +0800
commit246c433c7050fb67a0fa1e318f3863c06cd25832 (patch)
treebc02b88a8c03a7d64c518b342a4b0fcc60dc404e /shells/v7sh/Makefile
parent8c692d5dcb389a7a13bd337313738fdd892dcc26 (diff)
downloadfreebsd-ports-gnome-246c433c7050fb67a0fa1e318f3863c06cd25832.tar.gz
freebsd-ports-gnome-246c433c7050fb67a0fa1e318f3863c06cd25832.tar.zst
freebsd-ports-gnome-246c433c7050fb67a0fa1e318f3863c06cd25832.zip
Add v7sh, the original Steve R. Bourne shell from the 7th edition Unix including
System III, 4.3BSD-Reno, Ultrix 3.1 and `home made'' fixes and enhancements PR: ports/68127 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
Diffstat (limited to 'shells/v7sh/Makefile')
-rw-r--r--shells/v7sh/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/shells/v7sh/Makefile b/shells/v7sh/Makefile
new file mode 100644
index 000000000000..74aa1647a7f9
--- /dev/null
+++ b/shells/v7sh/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: v7sh
+# Date created: 4 June 2004
+# Whom: Cyrille.Lefevre@laposte.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= v7sh
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= ftp://minnie.tuhs.org/UnixArchive/PDP-11/Trees/V7/usr/src/cmd/sh/:s \
+ http://minnie.tuhs.org/UnixTree/V7/usr/src/cmd/sh/:s \
+ ftp://minnie.tuhs.org/UnixArchive/PDP-11/Trees/V7/usr/man/man1/:m \
+ http://minnie.tuhs.org/UnixTree/V7/usr/man/man1/:m
+DISTFILES= args.c:s blok.c:s brkincr.h:s builtin.c:s cmd.c:s \
+ ctype.c:s ctype.h:s defs.h:s error.c:s expand.c:s \
+ fault.c:s io.c:s mac.h:s macro.c:s main.c:s mode.h:s \
+ msg.c:s name.c:s name.h:s print.c:s service.c:s \
+ setbrk.c:s stak.c:s stak.h:s string.c:s sym.h:s \
+ timeout.h:s word.c:s xec.c:s sh.1:m
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= Cyrille.Lefevre@laposte.net
+COMMENT= An implementation of the UNIX 7th Edition shell
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+
+NO_WRKSUBDIR= yes
+MAN1= ${PORTNAME}.1
+
+OPTIONS= V7SH_SYSIII "System III enhancements" on \
+ V7SH_RENO "4.3BSD-Reno enhancements" on \
+ V7SH_ULTRIX "Ultrix 3.1 enhancements" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_V7SH_SYSIII)
+CFLAGS+= -DSYSIII
+.endif
+.if !defined(WITHOUT_V7SH_RENO)
+CFLAGS+= -DRENO
+.endif
+.if !defined(WITHOUT_V7SH_ULTRIX)
+CFLAGS+= -DULTRIX
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}/sh.1 ${WRKSRC}/${PORTNAME}.1
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+ @${CP} ${FILESDIR}/test.c ${WRKSRC} # sysIII
+ @${CP} ${FILESDIR}/pathnames.h ${WRKSRC} # 43reno
+.if ${OSVERSION} < 500005
+ @${CP} ${FILESDIR}/ulimit.[ch] ${WRKSRC} # fbsd52
+.endif
+
+post-install:
+ @${ECHO_MSG} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/${PORTNAME} /etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/${PORTNAME}) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.post.mk>