aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh-devel/Makefile
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>1999-10-29 22:39:47 +0800
committershige <shige@FreeBSD.org>1999-10-29 22:39:47 +0800
commit60c51a9bb6f64def65ebbadbc63aa7af80dfc122 (patch)
treeb5e71a0aa22e069e2a3976f2214a932358b7bcd4 /shells/zsh-devel/Makefile
parentd960c03b88b9de96e6d15cd09f7e0c50164fa2a4 (diff)
downloadfreebsd-ports-gnome-60c51a9bb6f64def65ebbadbc63aa7af80dfc122.tar.gz
freebsd-ports-gnome-60c51a9bb6f64def65ebbadbc63aa7af80dfc122.tar.zst
freebsd-ports-gnome-60c51a9bb6f64def65ebbadbc63aa7af80dfc122.zip
Fix reported in ports/14376 does not solve the problem essentially.
Therefore I solve the problem by the another way. Thank you for your bug-report. PR: ports/14376 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'shells/zsh-devel/Makefile')
-rw-r--r--shells/zsh-devel/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/shells/zsh-devel/Makefile b/shells/zsh-devel/Makefile
index 20626bcc5ac0..88b424e1196e 100644
--- a/shells/zsh-devel/Makefile
+++ b/shells/zsh-devel/Makefile
@@ -26,6 +26,17 @@ MAN1= zsh.1 zshbuiltins.1 zshcompctl.1 zshexpn.1 zshmisc.1 \
# If you want to build a static binary, uncomment the following line
#LDFLAGS+=-static
+post-build:
+# Fix ".so" macro problem by using "soelim" command.
+ @(cd ${WRKSRC} ; \
+ ${LN} -sf ./Doc man1 ; \
+ if [ ! -f ./man1/zshall.1.source ]; then \
+ ${MV} -f ./man1/zshall.1 ./man1/zshall.1.source ; \
+ fi ; \
+ ${RM} -f ./man1/zshall.1 ; \
+ /usr/bin/soelim ./man1/zshall.1.source > ./man1/zshall.1 ; \
+ )
+
post-install:
@${INSTALL_DATA} ${WRKSRC}/Doc/zsh.info ${PREFIX}/info
@install-info ${PREFIX}/info/zsh.info ${PREFIX}/info/dir