aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-11-22 09:44:09 +0800
committerbapt <bapt@FreeBSD.org>2014-11-22 09:44:09 +0800
commit85247ea8d40c3fedde6f2e0cb2d5926294a3d2cc (patch)
tree630a5fb1758e814d7a7b04edec8ba2f71b0cbdfe /shells/zsh
parentad55a43f09538b230a09fd463a5f46e0b610bebb (diff)
downloadfreebsd-ports-gnome-85247ea8d40c3fedde6f2e0cb2d5926294a3d2cc.tar.gz
freebsd-ports-gnome-85247ea8d40c3fedde6f2e0cb2d5926294a3d2cc.tar.zst
freebsd-ports-gnome-85247ea8d40c3fedde6f2e0cb2d5926294a3d2cc.zip
Add a patch the kld* completion to find modules in /boot/modules [1]
While here, fix manpages so they render correctly with mandoc PR: 194621 [1] Submitted by: clutton@zoho.com [1]
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile3
-rw-r--r--shells/zsh/files/patch-Completion_BSD_Command___kld11
-rw-r--r--shells/zsh/files/patch-Doc_zshmodules.110
3 files changed, 23 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index bbe3bf2938b8..145cb714c9e5 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zsh
PORTVERSION= 5.0.7
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
@@ -101,7 +102,7 @@ post-build:
# Fix ".so" macro problem by using "soelim" command.
${LN} -sf ${WRKSRC}/Doc ${WRKSRC}/man1
${MV} ${WRKSRC}/Doc/zshall.1 ${WRKSRC}/Doc/zshall.1.source
- cd ${WRKSRC} && /usr/bin/soelim ${WRKSRC}/Doc/zshall.1.source > \
+ cd ${WRKSRC} && ${SOELIM} -r ${WRKSRC}/Doc/zshall.1.source > \
${WRKSRC}/Doc/zshall.1
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${PREFIX}/info
diff --git a/shells/zsh/files/patch-Completion_BSD_Command___kld b/shells/zsh/files/patch-Completion_BSD_Command___kld
new file mode 100644
index 000000000000..7a49642520dc
--- /dev/null
+++ b/shells/zsh/files/patch-Completion_BSD_Command___kld
@@ -0,0 +1,11 @@
+--- Completion/BSD/Command/_kld.orig 2013-11-27 19:00:18 UTC
++++ Completion/BSD/Command/_kld
+@@ -4,7 +4,7 @@
+ _kld_module() {
+ local ret=1
+
+- compadd "$@" - /boot/kernel/*.ko(-.:t) /modules/*.ko(-.:t) && ret=0
++ compadd "$@" - /boot/{kernel,modules}/*.ko(-.:t) && ret=0
+ _files "$@" -g '*.ko(-.)' && ret=0
+
+ return ret
diff --git a/shells/zsh/files/patch-Doc_zshmodules.1 b/shells/zsh/files/patch-Doc_zshmodules.1
new file mode 100644
index 000000000000..d7e839541ae8
--- /dev/null
+++ b/shells/zsh/files/patch-Doc_zshmodules.1
@@ -0,0 +1,10 @@
+--- Doc/zshmodules.1.orig 2014-11-21 22:50:41 UTC
++++ Doc/zshmodules.1
+@@ -2415,7 +2415,6 @@ Returns the process ID of the current pr
+ Returns the process ID of the parent of the current process, even in
+ subshells\&. Compare \fB$PPID\fP, which returns the process ID of the parent
+ of the main shell process\&.
+-.RE
+ .SH "THE ZSH/NET/TCP MODULE"
+ .\" Yodl file: Zsh/mod_tcp.yo
+