aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-16 06:22:04 +0800
committerbapt <bapt@FreeBSD.org>2014-06-16 06:22:04 +0800
commit20d779de717c79b6161532d98bd1e01083f99960 (patch)
treeee6e67f140a8d964a017bf37a1c946017612f101 /shells/zsh
parente618a012ea440ed4639fded6f46c1bd0d18a5eaa (diff)
downloadfreebsd-ports-gnome-20d779de717c79b6161532d98bd1e01083f99960.tar.gz
freebsd-ports-gnome-20d779de717c79b6161532d98bd1e01083f99960.tar.zst
freebsd-ports-gnome-20d779de717c79b6161532d98bd1e01083f99960.zip
Only pickup iconv from base even if libiconv is installed [1]
While here do not leak stage path info zwc bytecode Reported & tested by: dim [1]
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 14c5935492e9..fa21a6c6134b 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -66,6 +66,10 @@ MULTIBYTE_CONFIGURE_ENABLE= multibyte
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
+CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
+.endif
+
.if ${PORT_OPTIONS:MDOCS}
INFO= zsh
.endif
@@ -116,7 +120,8 @@ post-install:
.endif
${STAGEDIR}${PREFIX}/bin/zsh -fc ' \
setopt extendedglob nomark_dirs; \
- for i in ${STAGEDIR}${DATADIR}/${ZSH_VER}/functions/**/*(/) ; do \
+ cd ${STAGEDIR}/${DATADIR}/${ZSH_VER} ; \
+ for i in functions/**/*(/) ; do \
zcompile -U -M $$i.zwc $$i/*~*.zwc(^/) ; \
${CHMOD} 644 $$i.zwc ; \
done'