aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-11 16:34:17 +0800
committerbapt <bapt@FreeBSD.org>2011-04-11 16:34:17 +0800
commit7c2279c9ea2445795906f17a17b4992ef5db8fe5 (patch)
treefa82e80371d6b2ded726b8ca4e53e49b52901507 /shells/zsh
parent00a8191fa754e9677dd68c7595adb287b76a451e (diff)
downloadfreebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.tar.gz
freebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.tar.zst
freebsd-ports-gnome-7c2279c9ea2445795906f17a17b4992ef5db8fe5.zip
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 6e51ea1a089e..35993c8c0463 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -25,6 +25,7 @@ USE_BZIP2= yes
USE_ICONV= yes
USE_AUTOTOOLS= autoconf autoheader
GNU_CONFIGURE= yes
+USE_NCURSES= yes
.if !defined(WITH_ZSH_STATIC)
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
.endif