aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-19 19:25:29 +0800
committermat <mat@FreeBSD.org>2016-06-19 19:25:29 +0800
commit44bb4707583cbd12af5d90026bb045ac8d948564 (patch)
tree84c7cf412c9b595212c74612c2651e087a7a7203 /shells
parentf3b7bc909dad478923eeefb92fdf5d952ed43b7b (diff)
downloadfreebsd-ports-gnome-44bb4707583cbd12af5d90026bb045ac8d948564.tar.gz
freebsd-ports-gnome-44bb4707583cbd12af5d90026bb045ac8d948564.tar.zst
freebsd-ports-gnome-44bb4707583cbd12af5d90026bb045ac8d948564.zip
Remove unnecessary evals that do-fetch was using.
Turns out that env(1) knows how to parse a properly quoted string using -S "string", it makes the double eval used for the fetch command to be unnecessary. This is because running: eval "foo $(escape $bar)" is silly when this works: foo $bar So remove escaping and quoting, and sillyness. PR: 210198 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6779
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 86a25c56773b..f222a95524c9 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -26,7 +26,7 @@ LICENSE= EPL
OPTIONS_DEFINE= EXAMPLES STATIC
-FETCH_ENV= HTTP_AUTH='basic:*:I accept www.opensource.org/licenses/cpl:.'
+FETCH_ENV= HTTP_AUTH=basic:*:I\ accept\ www.opensource.org/licenses/cpl:.
LDFLAGS+= -lm
MAKE_ENV= CCFLAGS="${CFLAGS}"
NO_WRKSUBDIR= yes