aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorasomers <asomers@FreeBSD.org>2017-02-11 13:23:19 +0800
committerasomers <asomers@FreeBSD.org>2017-02-11 13:23:19 +0800
commit55783b3c52670a6adbf3860c0b51f3682e680b7d (patch)
tree6c62e5325f4d0cd21978574ec1633dafb44a93ab /shells
parent3fb3ac13583ddcd8d8cb696b97c732696751310e (diff)
downloadfreebsd-ports-gnome-55783b3c52670a6adbf3860c0b51f3682e680b7d.tar.gz
freebsd-ports-gnome-55783b3c52670a6adbf3860c0b51f3682e680b7d.tar.zst
freebsd-ports-gnome-55783b3c52670a6adbf3860c0b51f3682e680b7d.zip
shells/fish: fix completions for python
Eliminate errors during command completion for python, python2, and python3 if the /usr/local/bin/python symlink does not exist. Additionally, even if the symlink does exist, the completions will be wrong for the non-default interpreter. So I'm simply deleting the problematic completions altogether. I opened an upstream bug for the latter issue. https://github.com/fish-shell/fish-shell/issues/3840 While I'm here, delete an extraneous patch file for DOCS=off PR: 216987 Reported by: Keren Sky <keren_sky@live.com> Approved by: brd (ports, implicit)
Diffstat (limited to 'shells')
-rw-r--r--shells/fish/Makefile4
-rw-r--r--shells/fish/files/extra-patch-Makefile.in21
-rw-r--r--shells/fish/files/patch-share_completions_python.fish18
3 files changed, 19 insertions, 24 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index ec206d10c4cd..732c1058c929 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fish
PORTVERSION= 2.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
@@ -28,8 +28,6 @@ NLS_USES= gettext
NLS_CONFIGURE_ENV= ac_cv_func_gettext=yes
NLS_CONFIGURE_OFF= --without-gettext
-DOCS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Makefile.in
-
post-patch:
@${REINPLACE_CMD} -e \
'/^all:/s|user_doc|| ; \
diff --git a/shells/fish/files/extra-patch-Makefile.in b/shells/fish/files/extra-patch-Makefile.in
deleted file mode 100644
index 83ab3bc29588..000000000000
--- a/shells/fish/files/extra-patch-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig 2017-01-17 16:12:49 UTC
-+++ Makefile.in
-@@ -701,12 +701,12 @@ install-force: all install-translations
- true; \
- done;
- @echo "Installing online user documentation";
-- $v $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
-- $v for i in user_doc/html/* CHANGELOG.md; do \
-- if test -f $$i; then \
-- $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
-- fi; \
-- done;
-+# $v $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
-+# $v for i in user_doc/html/* CHANGELOG.md; do \
-+# if test -f $$i; then \
-+# $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
-+# fi; \
-+# done;
- @echo "Installing more man pages";
- $v $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1;
- $v for i in $(MANUALS); do \
diff --git a/shells/fish/files/patch-share_completions_python.fish b/shells/fish/files/patch-share_completions_python.fish
new file mode 100644
index 000000000000..a8cd43c851d6
--- /dev/null
+++ b/shells/fish/files/patch-share_completions_python.fish
@@ -0,0 +1,18 @@
+--- share/completions/python.fish.orig 2017-02-11 04:56:23 UTC
++++ share/completions/python.fish
+@@ -16,15 +16,3 @@ complete -c python -s W -x --description
+ complete -c python -s x -d 'Skip first line of source, allowing use of non-Unix forms of #!cmd'
+ complete -c python -a "(__fish_complete_suffix .py)"
+ complete -c python -a '-' -d 'Read program from stdin'
+-
+-switch (python -V 2>&1 | string replace -r '^.*\s([23])..*' '$1')[1]
+- case 2
+- complete -c python -s 3 -d 'Warn about Python 3.x incompatibilities that 2to3 cannot trivially fix'
+- complete -c python -s t --description "Warn on mixed tabs and spaces"
+- complete -c python -s Q -x -a "old new warn warnall" --description "Division control"
+- case 3
+- complete -c python -s q --description 'Don\'t print version and copyright messages on interactive startup'
+- complete -c python -s X -x -d 'Set implementation-specific option'
+- complete -c python -s b -d 'Issue warnings about str(bytes_instance), str(bytearray_instance) and comparing bytes/bytearray with str'
+- complete -c python -o bb -d 'Issue errors'
+-end