aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-22 18:02:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-22 18:02:45 +0800
commit72c33d5922c112d0e02347d9a963f58c7fd8081d (patch)
tree5e3886832bd5ae67fd79ffa80a0b03557d1492eb /shells
parentbfc05f177ba37727aac59291e5d0162c3054c455 (diff)
downloadfreebsd-ports-gnome-72c33d5922c112d0e02347d9a963f58c7fd8081d.tar.gz
freebsd-ports-gnome-72c33d5922c112d0e02347d9a963f58c7fd8081d.tar.zst
freebsd-ports-gnome-72c33d5922c112d0e02347d9a963f58c7fd8081d.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'shells')
-rw-r--r--shells/ibsh/Makefile11
-rw-r--r--shells/ibsh/files/patch-Makefile6
2 files changed, 11 insertions, 6 deletions
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
index bd780ba4a7e2..a2f75fb6581a 100644
--- a/shells/ibsh/Makefile
+++ b/shells/ibsh/Makefile
@@ -9,7 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Restricted unix shell
-OPTIONS_DEFINE= DOCS
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake
ALL_TARGET= ibsh
@@ -20,13 +21,17 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS BUGS CONTRIBUTORS COPYING COPYRIGHT ChangeLog \
INSTALL README TODO VERSION
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|PATH_MAX|PATH_MAXb|g' ${WRKSRC}/delbadfiles.c ${WRKSRC}/ibsh.h
@${REINPLACE_CMD} -e 's|/etc/ibsh|${PREFIX}/etc/ibsh|g' ${WRKSRC}/ibsh.h
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ibsh
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ibsh
.include <bsd.port.mk>
diff --git a/shells/ibsh/files/patch-Makefile b/shells/ibsh/files/patch-Makefile
index 6168d71f5751..eee459054000 100644
--- a/shells/ibsh/files/patch-Makefile
+++ b/shells/ibsh/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Fri Jun 3 15:47:32 2005
-+++ Makefile Sat Nov 12 13:47:53 2005
-@@ -30,12 +30,12 @@
+--- Makefile.orig 2005-06-03 13:47:32 UTC
++++ Makefile
+@@ -30,12 +30,12 @@ delbadfiles.o: delbadfiles.c ibsh.h
${CC} -c delbadfiles.c
ibsh_install: