aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorcem <cem@FreeBSD.org>2015-07-31 02:50:18 +0800
committercem <cem@FreeBSD.org>2015-07-31 02:50:18 +0800
commit9dbce374ca868eb9a420bd0bdd5b6c096ff85995 (patch)
tree8e93ffeee0828d575395f8efcbfe9caba66b2672 /shells
parentbafcc03873e0da85908f542e397ca181fa36dd17 (diff)
downloadfreebsd-ports-gnome-9dbce374ca868eb9a420bd0bdd5b6c096ff85995.tar.gz
freebsd-ports-gnome-9dbce374ca868eb9a420bd0bdd5b6c096ff85995.tar.zst
freebsd-ports-gnome-9dbce374ca868eb9a420bd0bdd5b6c096ff85995.zip
bash: Export symbols for "enable -f"
PR: 201959 Reviewed by: ehaupt Approved by: markj (mentor) Sponsored by: EMC / Isilon Storage Division Differential Revision: https://reviews.freebsd.org/D3231
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 2ed80f0ae535..90b7f60228d6 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 39
PORTVERSION= 4.3.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -74,6 +74,9 @@ CFLAGS+= -DIMPORT_FUNCTIONS_DEF=0
CONFIGURE_ARGS+= --enable-static-link
.else
CONFIGURE_ARGS+= --disable-static-link
+# Bash symbols must be exported in order to link runtime plugins, i.e.,
+# "enable -f". (Plugins are not supported for bash-static.)
+CFLAGS+= -Wl,-export-dynamic
.endif
post-patch: