aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-20 02:30:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-20 02:30:35 +0800
commit2862d547f7dd47847c6065a3825c169df559b9ef (patch)
tree1f526fed309730e4ce7e06f0f28c60daa6cc05f0 /shells
parent8edf269effba5b4c7d69da93d153e54dcd19691d (diff)
downloadfreebsd-ports-gnome-2862d547f7dd47847c6065a3825c169df559b9ef.tar.gz
freebsd-ports-gnome-2862d547f7dd47847c6065a3825c169df559b9ef.tar.zst
freebsd-ports-gnome-2862d547f7dd47847c6065a3825c169df559b9ef.zip
- Use @dirrmtry for PREFIX/etc/bash_completion.d
Other ports (e.g. devel/glib20) install files to this directory. - Costmetic change: put build-related knobs together - Sort PLIST - Space/tab twiddle PR: ports/160202 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 24 days)
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile25
-rw-r--r--shells/bash-completion/pkg-plist4
2 files changed, 14 insertions, 15 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 2efd03de6858..c3facc12485f 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -5,25 +5,24 @@
# $FreeBSD$
#
-PORTNAME= bash-completion
+PORTNAME= bash-completion
PORTVERSION= 1.3
-PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= shells
+PORTREVISION= 2
+PORTEPOCH= 1
+CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
-MAINTAINER= adamw@FreeBSD.org
-COMMENT= Programmable completion library for Bash
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Programmable completion library for Bash
-USE_BZIP2= yes
-SUB_FILES= pkg-message
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-CONFLICTS+= bash-completion-classic-[0-9]*
+CONFLICTS= bash-completion-classic-[0-9]*
GNU_CONFIGURE= yes
+USE_BZIP2= yes
-.include <bsd.port.pre.mk>
+SUB_FILES= pkg-message
post-patch:
@${ECHO_CMD} You can safely ignore this next error...
@@ -36,11 +35,11 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|' \
+ s|FLAC|&\|flv\|FLV|' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in \
${WRKSRC}/completions/* ${WRKSRC}/completions/helpers/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 16a1b985b764..d7faf9afc7e5 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -107,8 +107,8 @@ etc/bash_completion.d/ncftp
etc/bash_completion.d/net-tools
etc/bash_completion.d/nmap
etc/bash_completion.d/ntpdate
-etc/bash_completion.d/openldap
etc/bash_completion.d/open-iscsi
+etc/bash_completion.d/openldap
etc/bash_completion.d/openssl
etc/bash_completion.d/p4
etc/bash_completion.d/perl
@@ -181,4 +181,4 @@ etc/bash_completion.d/xz
etc/bash_completion.d/yp-tools
etc/bash_completion.d/yum-arch
@dirrm etc/bash_completion.d/helpers
-@dirrm etc/bash_completion.d
+@dirrmtry etc/bash_completion.d