aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2008-05-06 19:52:45 +0800
committerdes <des@FreeBSD.org>2008-05-06 19:52:45 +0800
commit4a075bb5cb7d01545e8835a7c37506d831665d16 (patch)
tree8b922a817cc5053179e9035347815d02b1073006 /shells
parentcb638a8c907061d9a51c8e4c8a3c551940e2b316 (diff)
downloadfreebsd-ports-gnome-4a075bb5cb7d01545e8835a7c37506d831665d16.tar.gz
freebsd-ports-gnome-4a075bb5cb7d01545e8835a7c37506d831665d16.tar.zst
freebsd-ports-gnome-4a075bb5cb7d01545e8835a7c37506d831665d16.zip
Better version of the previous commit, with an unconditional patch this
time. The patch has been submitted upstream.
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile9
-rw-r--r--shells/zsh/files/patch-ncurses (renamed from shells/zsh/files/extra-patch-ncurses)8
2 files changed, 7 insertions, 10 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 7172e8c95c7f..48182f50650e 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -35,7 +35,7 @@ ZSH_VER= ${PORTVERSION}
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:261:env
+USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
@@ -73,11 +73,6 @@ SHELLS= /etc/shells
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 602107
-# also needed for early versions of 7.0-CURRENT, but we don't care
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ncurses
-.endif
-
.if defined(WITH_ZSH_PCRE)
CONFIGURE_ARGS+= --enable-pcre
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
@@ -109,7 +104,7 @@ CONFIGURE_ARGS+= --enable-multibyte
.endif
.if ${OSVERSION} >= 503000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsdtar
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
.endif
post-patch:
diff --git a/shells/zsh/files/extra-patch-ncurses b/shells/zsh/files/patch-ncurses
index f0a1bc2c7f28..6a84cac3a901 100644
--- a/shells/zsh/files/extra-patch-ncurses
+++ b/shells/zsh/files/patch-ncurses
@@ -12,17 +12,19 @@
+[Define if _XOPEN_SOURCE_EXTENDED should not be defined to avoid clashes])
+AC_CACHE_CHECK(if _XOPEN_SOURCE_EXTENDED should not be defined,
+zsh_cv_no_xopen,
- [case "$host_os" in
+-[case "$host_os" in
- *openbsd*)
- zsh_cv_curses_needs_xopen=no
-+ *openbsd*|*freebsd*)
++[[case "$host_os" in
++ *openbsd*|*freebsd5*|*freebsd6.[012]*)
+ zsh_cv_no_xopen=yes
;;
*)
- zsh_cv_curses_needs_xopen=yes
+ zsh_cv_no_xopen=no
;;
- esac])
+-esac])
++esac]])
-if test x$zsh_cv_curses_needs_xopen = xyes; then
- AC_DEFINE(ZSH_CURSES_NEEDS_XOPEN)
+if test x$zsh_cv_no_xopen = xyes; then