aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-04-22 20:39:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-04-22 20:39:10 +0800
commit93f52d56e2a2c28e0cf56b378b0d04b2be316aaf (patch)
tree2cd75f48d9a72fe45f0bb9daeb96ba7ebf7ceabb /shells
parentc46b046716163d85f4d914d95f3ad83a4bd33242 (diff)
downloadfreebsd-ports-gnome-93f52d56e2a2c28e0cf56b378b0d04b2be316aaf.tar.gz
freebsd-ports-gnome-93f52d56e2a2c28e0cf56b378b0d04b2be316aaf.tar.zst
freebsd-ports-gnome-93f52d56e2a2c28e0cf56b378b0d04b2be316aaf.zip
Make bash use of fdescfs use optional, disabled by default, and forced off when
disabled. This allows users to avoid mounting an extra FS that we don't enable by default. Only display pkg-message with fdescfs instructions when option is enabled. Submitted by: swills Differential Revision: https://reviews.freebsd.org/D10394
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile8
-rw-r--r--shells/bash/files/pkg-message.in (renamed from shells/bash/pkg-message)0
2 files changed, 6 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index b726f4ce6ce7..e7f2d40cb0b5 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 12
PORTVERSION= 4.4.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -22,8 +22,9 @@ COMMENT= GNU Project's Bourne Again SHell
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= COLONBREAKSWORDS HELP NLS STATIC SYSLOG DOCS
+OPTIONS_DEFINE= COLONBREAKSWORDS FDESCFS HELP NLS STATIC SYSLOG DOCS
COLONBREAKSWORDS_DESC= Colons break words
+FDESCFS_DESC= Enable use of /dev/fd
HELP_DESC= Enable builtin help
OPTIONS_DEFAULT= COLONBREAKSWORDS HELP
@@ -35,6 +36,9 @@ CPE_VENDOR= gnu
COLONBREAKSWORDS_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-colonbreakswords
+FDESCFS_CONFIGURE_ENV_OFF= bash_cv_dev_fd=absent
+FDESCFS_SUB_FILES= pkg-message
+
HELP_CONFIGURE_ENABLE= help-builtin
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
diff --git a/shells/bash/pkg-message b/shells/bash/files/pkg-message.in
index 14dfcfe895f7..14dfcfe895f7 100644
--- a/shells/bash/pkg-message
+++ b/shells/bash/files/pkg-message.in