aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-21 06:16:38 +0800
committerbapt <bapt@FreeBSD.org>2012-07-21 06:16:38 +0800
commita7ccd08e02b778d6bfc2195561e132b9a10dbff3 (patch)
treefac29c92f7999f8b0504b3637755d4c30912a87c /shells
parent7d4625e011c94182d6eb34e7282068aec0d69574 (diff)
downloadfreebsd-ports-gnome-a7ccd08e02b778d6bfc2195561e132b9a10dbff3.tar.gz
freebsd-ports-gnome-a7ccd08e02b778d6bfc2195561e132b9a10dbff3.tar.zst
freebsd-ports-gnome-a7ccd08e02b778d6bfc2195561e132b9a10dbff3.zip
Convert to new options framework
Diffstat (limited to 'shells')
-rw-r--r--shells/v7sh/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/shells/v7sh/Makefile b/shells/v7sh/Makefile
index 209ac769f491..e6111230bd39 100644
--- a/shells/v7sh/Makefile
+++ b/shells/v7sh/Makefile
@@ -31,19 +31,21 @@ NO_WRKSUBDIR= yes
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
-OPTIONS= V7SH_SYSIII "System III enhancements" on \
- V7SH_RENO "4.3BSD-Reno enhancements" on \
- V7SH_ULTRIX "Ultrix 3.1 enhancements" on
+OPTIONS_DEFINE= SYSIII RENO ULTRIX
+OPTIONS_DEFAULT= SYSIII RENO ULTRIX
+SYSIII_DESC= System III enhancements
+RENO_DESC= 4.3BSD-Reno enhancements
+ULTRIX_DESC= Ultrix 3.1 enhancements
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_V7SH_SYSIII)
+.if ${PORT_OPTIONS:MSYSIII}
CFLAGS+= -DSYSIII
.endif
-.if !defined(WITHOUT_V7SH_RENO)
+.if ${PORT_OPTIONS:MRENO}
CFLAGS+= -DRENO
.endif
-.if !defined(WITHOUT_V7SH_ULTRIX)
+.if ${PORT_OPTIONS:MULTRIX}
CFLAGS+= -DULTRIX
.endif
@@ -60,4 +62,4 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/${PORTNAME}) > /etc/shells
@${RM} /etc/shells.bak
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>