aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-30 09:31:08 +0800
committerwill <will@FreeBSD.org>2000-12-30 09:31:08 +0800
commitd1e264ab741debad23415fa7f416f3d56e803b05 (patch)
tree7c61e18ae8e5811430ed912d87234fcf387ce2cf /shells
parent3db5d629851671adb6f351bb6c04bce035643534 (diff)
downloadfreebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.tar.gz
freebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.tar.zst
freebsd-ports-gnome-d1e264ab741debad23415fa7f416f3d56e803b05.zip
Add osh 001127, a reimplementation of the old and obsolete shell version
that was in standard use up to UNIX 6th Edition and was supplied as osh with UNIX 7th Edition. Its command language is a sparse subset of those of modern shells and is mostly common to both sh(1) and csh(1). PR: 23943 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/osh/Makefile26
-rw-r--r--shells/osh/distinfo1
-rw-r--r--shells/osh/files/patch-aa21
-rw-r--r--shells/osh/files/patch-ab28
-rw-r--r--shells/osh/pkg-comment1
-rw-r--r--shells/osh/pkg-descr8
-rw-r--r--shells/osh/pkg-plist3
8 files changed, 89 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index b00d2a71bd3a..2032a7b9c5be 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -8,6 +8,7 @@
SUBDIR += esh
SUBDIR += flash
SUBDIR += ksh93
+ SUBDIR += osh
SUBDIR += pdksh
SUBDIR += perlsh
SUBDIR += rc
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
new file mode 100644
index 000000000000..59531ba59338
--- /dev/null
+++ b/shells/osh/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: osh
+# Date created: 29 December 2000
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osh
+PORTVERSION= 001127
+CATEGORIES= shells
+MASTER_SITES= http://omnibus.ruf.uni-freiburg.de/~gritter/archive/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+MAKEFILE= makefile
+
+MAN1= osh.1
+
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/osh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/osh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>
diff --git a/shells/osh/distinfo b/shells/osh/distinfo
new file mode 100644
index 000000000000..a2a44bd65ed7
--- /dev/null
+++ b/shells/osh/distinfo
@@ -0,0 +1 @@
+MD5 (osh-001127.tar.gz) = 96cc2541d8bcdf5996243c14ea4d224a
diff --git a/shells/osh/files/patch-aa b/shells/osh/files/patch-aa
new file mode 100644
index 000000000000..e3678c333e48
--- /dev/null
+++ b/shells/osh/files/patch-aa
@@ -0,0 +1,21 @@
+--- makefile.orig Mon Nov 27 19:32:14 2000
++++ makefile Fri Dec 29 15:31:35 2000
+@@ -7,11 +7,10 @@
+ #CPPFLAGS =
+ #LDFLAGS =
+ #LIBS = -lefence
+-PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man
+ MANSECT = $(MANDIR)/man1
+-INSTALL = /usr/ucb/install
++INSTALL = /usr/bin/install
+
+ # CONFIGURATION ENDS
+
+@@ -41,4 +40,4 @@
+ install:
+ $(MAKE)
+ $(INSTALL) -c -s $(EXE) $(BINDIR)
+- $(INSTALL) -c -m 644 $(MAN) $(MANSECT)
++ $(INSTALL) -c -m 444 $(MAN) $(MANSECT)
diff --git a/shells/osh/files/patch-ab b/shells/osh/files/patch-ab
new file mode 100644
index 000000000000..ef856e14789f
--- /dev/null
+++ b/shells/osh/files/patch-ab
@@ -0,0 +1,28 @@
+--- osh.c.orig Fri Dec 29 15:38:16 2000
++++ osh.c Fri Dec 29 15:38:32 2000
+@@ -494,9 +494,9 @@
+ if (input != stdin)
+ fclose(input);
+ #endif
+- sigset(SIGINT, SIG_DFL);
+- sigset(SIGQUIT, SIG_DFL);
+- sigset(SIGTERM, SIG_DFL);
++ signal(SIGINT, SIG_DFL);
++ signal(SIGQUIT, SIG_DFL);
++ signal(SIGTERM, SIG_DFL);
+ if (flags & FL_ASYNC)
+ setpgid(0, 0);
+ /* try current directory first */
+@@ -779,9 +779,9 @@
+ if (isatty(0)) {
+ interactive = 1;
+ setpgid(0, 0);
+- sigset(SIGINT, SIG_IGN);
+- sigset(SIGQUIT, SIG_IGN);
+- sigset(SIGTERM, SIG_IGN);
++ signal(SIGINT, SIG_IGN);
++ signal(SIGQUIT, SIG_IGN);
++ signal(SIGTERM, SIG_IGN);
+ }
+ } else {
+ fclose(stdin); /* the external goto command needs this */
diff --git a/shells/osh/pkg-comment b/shells/osh/pkg-comment
new file mode 100644
index 000000000000..4183f972a01a
--- /dev/null
+++ b/shells/osh/pkg-comment
@@ -0,0 +1 @@
+An implementation of the UNIX 6th Edition shell.
diff --git a/shells/osh/pkg-descr b/shells/osh/pkg-descr
new file mode 100644
index 000000000000..b092e1c78178
--- /dev/null
+++ b/shells/osh/pkg-descr
@@ -0,0 +1,8 @@
+Osh is a re-implementation of the old and obsolete shell version,
+which was in standard use up to UNIX 6th Edition and was supplied
+as osh with UNIX 7th Edition. Its command language is a sparse
+subset of those of modern shells and is mostly common both to sh(1)
+and csh(1).
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/shells/osh/pkg-plist b/shells/osh/pkg-plist
new file mode 100644
index 000000000000..01dcc9032720
--- /dev/null
+++ b/shells/osh/pkg-plist
@@ -0,0 +1,3 @@
+bin/osh
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells