aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-03-26 05:04:50 +0800
committerknu <knu@FreeBSD.org>2002-03-26 05:04:50 +0800
commit0e26586f3bfbeba5b06c45ca3071ac74edd458b6 (patch)
tree4eadb27325644aa9e1583dbeeeceb62c6236203b /shells
parent92849fa9e1ea7fc16e26aa59adf66c0d362dc257 (diff)
downloadfreebsd-ports-gnome-0e26586f3bfbeba5b06c45ca3071ac74edd458b6.tar.gz
freebsd-ports-gnome-0e26586f3bfbeba5b06c45ca3071ac74edd458b6.tar.zst
freebsd-ports-gnome-0e26586f3bfbeba5b06c45ca3071ac74edd458b6.zip
Add a patch supplied by the author to fix a bug in glob expansion
where a series of globs was only partially expanded. (`echo a* b*' -> `echo a aa aaa b*') Bump PORTREVISION accordingly.
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-pathname.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 33ef514bb589..362c18b0f1dd 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 2.00a
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.vector.co.jp/pack/unix/util/file/filer/fd/
diff --git a/shells/fd/files/patch-pathname.c b/shells/fd/files/patch-pathname.c
new file mode 100644
index 000000000000..d4b22a267299
--- /dev/null
+++ b/shells/fd/files/patch-pathname.c
@@ -0,0 +1,12 @@
+diff -u ../old/FD-2.00a/pathname.c ./pathname.c
+--- ../old/FD-2.00a/pathname.c Wed Feb 6 00:00:00 2002
++++ ./pathname.c Fri Mar 22 08:55:40 2002
+@@ -2744,7 +2744,7 @@
+ for (w = 0; wild[w]; w++)
+ (*argvp)[n + w] = wild[w];
+ free(wild);
+- n += w;
++ n += w - 1;
+ break;
+ }
+