aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-05-30 04:34:46 +0800
committerpawel <pawel@FreeBSD.org>2015-05-30 04:34:46 +0800
commit433ad797fa53f5d81b59af170371c2698f081543 (patch)
tree6637ae90a6568cc1addfe8d7429ae284211dfd50 /shells
parent3d87cae0501922d8b9cb0e4f20bb52c09e0e3280 (diff)
downloadfreebsd-ports-gnome-433ad797fa53f5d81b59af170371c2698f081543.tar.gz
freebsd-ports-gnome-433ad797fa53f5d81b59af170371c2698f081543.tar.zst
freebsd-ports-gnome-433ad797fa53f5d81b59af170371c2698f081543.zip
Wcd is a command-line program to change directory fast. It saves time typing
at the keyboard. One needs to type only a part of a directory name and wcd will jump to it. Wcd has a fast selection method in case of multiple matches and allows aliasing and banning of directories. Wcd also includes a full screen interactive directory tree browser with speed search. WWW: http://wcd.sourceforge.net/
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/wcd/Makefile38
-rw-r--r--shells/wcd/distinfo2
-rw-r--r--shells/wcd/pkg-descr7
-rw-r--r--shells/wcd/pkg-plist29
5 files changed, 77 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 0f0ef3c18f10..0b9a9b56c7a1 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -41,6 +41,7 @@
SUBDIR += v7sh
SUBDIR += viewglob
SUBDIR += vshnu
+ SUBDIR += wcd
SUBDIR += zsh
.include <bsd.port.subdir.mk>
diff --git a/shells/wcd/Makefile b/shells/wcd/Makefile
new file mode 100644
index 000000000000..605e73162039
--- /dev/null
+++ b/shells/wcd/Makefile
@@ -0,0 +1,38 @@
+# Created by: Pawel Pekala <pawel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wcd
+PORTVERSION= 5.2.7
+CATEGORIES= shells
+MASTER_SITES= SF
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Command-line program to change directory fast
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/copying.txt
+
+USES= gmake
+MAKE_ARGS= EXT= PREFIX=${PREFIX} docsubdir=${PORTNAME} \
+ mandir=${PREFIX}/man
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MNLS}
+MAKE_ARGS+= ENABLE_NLS=
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/manfile/ s|datarootdir|prefix|' \
+ -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/src/Makefile
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/wcd
+
+.include <bsd.port.mk>
diff --git a/shells/wcd/distinfo b/shells/wcd/distinfo
new file mode 100644
index 000000000000..ca3f02390a51
--- /dev/null
+++ b/shells/wcd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wcd-5.2.7.tar.gz) = e5f56824e054c6726186271b20a5de3c5b167116b97785a925907981cf3e3b39
+SIZE (wcd-5.2.7.tar.gz) = 622613
diff --git a/shells/wcd/pkg-descr b/shells/wcd/pkg-descr
new file mode 100644
index 000000000000..e170f427c2d7
--- /dev/null
+++ b/shells/wcd/pkg-descr
@@ -0,0 +1,7 @@
+Wcd is a command-line program to change directory fast. It saves time typing
+at the keyboard. One needs to type only a part of a directory name and wcd
+will jump to it. Wcd has a fast selection method in case of multiple matches
+and allows aliasing and banning of directories. Wcd also includes a full
+screen interactive directory tree browser with speed search.
+
+WWW: http://wcd.sourceforge.net/
diff --git a/shells/wcd/pkg-plist b/shells/wcd/pkg-plist
new file mode 100644
index 000000000000..6e0cffb552a9
--- /dev/null
+++ b/shells/wcd/pkg-plist
@@ -0,0 +1,29 @@
+bin/wcd
+man/de/man1/wcd.1.gz
+man/man1/wcd.1.gz
+man/nl/man1/wcd.1.gz
+man/uk/man1/wcd.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/RPM.txt
+%%PORTDOCS%%%%DOCSDIR%%/UNIX.txt
+%%PORTDOCS%%%%DOCSDIR%%/copying.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/wcd.htm
+%%PORTDOCS%%%%DOCSDIR%%/de/wcd.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/nl/wcd.htm
+%%PORTDOCS%%%%DOCSDIR%%/nl/wcd.txt
+%%PORTDOCS%%%%DOCSDIR%%/problems.txt
+%%PORTDOCS%%%%DOCSDIR%%/todo.txt
+%%PORTDOCS%%%%DOCSDIR%%/uk/wcd.htm
+%%PORTDOCS%%%%DOCSDIR%%/uk/wcd.txt
+%%PORTDOCS%%%%DOCSDIR%%/wcd.htm
+%%PORTDOCS%%%%DOCSDIR%%/wcd.txt
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
+%%NLS%%share/locale/de/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/es/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/wcd.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/wcd.mo