aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /shells
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/zsh-devel/Makefile2
-rw-r--r--shells/zsh/Makefile2
3 files changed, 5 insertions, 4 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 276c203e2937..e6ae1fa86f11 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -25,7 +25,7 @@ PATCHFILES+= ${PORTNAME}${PORTVERSION:R:S/.//g}-0${patch}:bash
PATCHLEVEL= ${patch}
.endfor
-MAINTAINER= eik@FreeBSD.org
+MAINTAINER= eik@FreeBSD.org, obrien@FreeBSD.org
COMMENT= The GNU Project's Bourne Again SHell
IGNOREFILES= FAQ
@@ -53,6 +53,7 @@ PORTDOCS= FAQ INTRO CHANGES COMPAT NEWS POSIX RBASH
.endif
CONFIGURE_ARGS= --without-bash-malloc \
+ --with-installed-readline \
--disable-rpath \
--enable-disabled-builtins
@@ -74,7 +75,7 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
diff --git a/shells/zsh-devel/Makefile b/shells/zsh-devel/Makefile
index 4333956efb09..72c7949e2cd9 100644
--- a/shells/zsh-devel/Makefile
+++ b/shells/zsh-devel/Makefile
@@ -63,7 +63,7 @@ CONFLICTS= zsh-4.0.*
USE_BZIP2= yes
GNU_CONFIGURE= yes
-#CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+#CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-etcdir=${ZSH_ETCDIR} --with-curses-terminfo \
--enable-fndir=${ZSH_FNDIR} --enable-function-subdirs \
--enable-site-fndir=${ZSH_SITEFNDIR}
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 29b58a2b1572..c127f88a8a42 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -60,7 +60,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-curses-terminfo --with-tcsetpgrp \
--enable-etcdir=${ZSH_ETCDIR} \
--enable-fndir=${ZSH_FNDIR} --enable-function-subdirs \