aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
commit6baece3b7ae06d93445a0e0ecf02e59541a92a95 (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /shells
parentc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (diff)
downloadfreebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.gz
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.zst
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'shells')
-rw-r--r--shells/44bsd-csh/Makefile2
-rw-r--r--shells/heirloom-sh/Makefile2
-rw-r--r--shells/jailkit/Makefile2
-rw-r--r--shells/lshell/Makefile2
-rw-r--r--shells/osh/Makefile2
5 files changed, 10 insertions, 0 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
index 6f1e877f1baf..7d96705c1499 100644
--- a/shells/44bsd-csh/Makefile
+++ b/shells/44bsd-csh/Makefile
@@ -18,6 +18,8 @@ USES= tar:bzip2
NO_WRKSUBDIR= yes
PORTDOCS= paper.ascii.gz
+OPTIONS_DEFINE= DOCS
+
post-extract:
cd ${WRKSRC} ; co RCS/*,v; chmod u+w *
cd ${WRKSRC}/USD.doc ; co RCS/*,v
diff --git a/shells/heirloom-sh/Makefile b/shells/heirloom-sh/Makefile
index e810852c83ab..becc941cf370 100644
--- a/shells/heirloom-sh/Makefile
+++ b/shells/heirloom-sh/Makefile
@@ -20,6 +20,8 @@ PORTDOCS= CALDERA.LICENSE OPENSOLARIS.LICENSE CHANGES README
PKGINSTALL= pkg-install
PKGDEINSTALL= pkg-deinstall
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jsh ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/sh.1.out ${STAGEDIR}${MANPREFIX}/man/man1/jsh.1
diff --git a/shells/jailkit/Makefile b/shells/jailkit/Makefile
index 45b3a82e3ad9..40021bddb8ce 100644
--- a/shells/jailkit/Makefile
+++ b/shells/jailkit/Makefile
@@ -19,6 +19,8 @@ CONFIGURE_ENV= PYTHONINTERPRETER=${PYTHON_CMD}
PORTDOCS= COPYRIGHT README.txt
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index d74e66a80fee..00efead8d1bc 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -19,6 +19,8 @@ USES= python:2.7
USE_GITHUB= yes
USE_PYTHON= distutils
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
"s|(.*lshell.conf.*),|| ; \
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
index 98e6ffe8abd3..0743a8fa3f9b 100644
--- a/shells/osh/Makefile
+++ b/shells/osh/Makefile
@@ -18,6 +18,8 @@ PORTEXAMPLES= *
INSTALL_TARGET= install install-doc install-exp
PLIST_SUB+= VER=${DISTVERSION}
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -E -e 's|(DESTEXPDIR)=|\1?=|' \
${WRKSRC}/Makefile