aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-06 18:07:19 +0800
committermarino <marino@FreeBSD.org>2015-02-06 18:07:19 +0800
commit975d830b26609ff19b5df62d857d50b6ddf0ffd6 (patch)
treed7a11a0c3905728ffd41c584401da523efe3775e /shells
parent319f0323306b1fce5b6771e4f273f7797725fb6f (diff)
downloadfreebsd-ports-gnome-975d830b26609ff19b5df62d857d50b6ddf0ffd6.tar.gz
freebsd-ports-gnome-975d830b26609ff19b5df62d857d50b6ddf0ffd6.tar.zst
freebsd-ports-gnome-975d830b26609ff19b5df62d857d50b6ddf0ffd6.zip
shells/lshell: fix syslog file location (/dev/log => /var/run/log)
PR: 195245 Submitted by: dam (my.gd) Approved by: n/a (unmaintained)
Diffstat (limited to 'shells')
-rw-r--r--shells/lshell/Makefile1
-rw-r--r--shells/lshell/files/patch-lshell_checkconfig.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
index adf208fc5943..248aa3e21526 100644
--- a/shells/lshell/Makefile
+++ b/shells/lshell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lshell
PORTVERSION= 0.9.16
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF
diff --git a/shells/lshell/files/patch-lshell_checkconfig.py b/shells/lshell/files/patch-lshell_checkconfig.py
new file mode 100644
index 000000000000..6427ccffc8b4
--- /dev/null
+++ b/shells/lshell/files/patch-lshell_checkconfig.py
@@ -0,0 +1,11 @@
+--- lshell/checkconfig.py.orig 2013-08-19 19:59:37 UTC
++++ lshell/checkconfig.py
+@@ -307,7 +307,7 @@ class CheckConfig:
+ try:
+ if logfilename == "syslog":
+ from logging.handlers import SysLogHandler
+- syslog = SysLogHandler(address='/dev/log')
++ syslog = SysLogHandler(address='/var/run/log')
+ syslog.setFormatter(syslogformatter)
+ syslog.setLevel(self.levels[self.conf['loglevel']])
+ logger.addHandler(syslog)