aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-08-11 03:32:19 +0800
committereik <eik@FreeBSD.org>2004-08-11 03:32:19 +0800
commit17d33ba9b22c3da44d76540567f74039a55e8e93 (patch)
tree82e637fd37565abe36a84c3f36793859fdd3cec3 /shells
parent61699cc540b45977d58091d91187e77eb103bf5e (diff)
downloadfreebsd-ports-gnome-17d33ba9b22c3da44d76540567f74039a55e8e93.tar.gz
freebsd-ports-gnome-17d33ba9b22c3da44d76540567f74039a55e8e93.tar.zst
freebsd-ports-gnome-17d33ba9b22c3da44d76540567f74039a55e8e93.zip
Fix nested brace vs. variable expansion
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash/files/patch-braces.c15
-rw-r--r--shells/bash3/Makefile2
-rw-r--r--shells/bash3/files/patch-braces.c15
4 files changed, 32 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 6934c16e2180..567a2d564228 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bash
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/
diff --git a/shells/bash/files/patch-braces.c b/shells/bash/files/patch-braces.c
new file mode 100644
index 000000000000..591d58ef3888
--- /dev/null
+++ b/shells/bash/files/patch-braces.c
@@ -0,0 +1,15 @@
+#
+# Fix nested brace vs. variable expansion
+#
+# http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00056.html
+#
+--- braces.c.orig Tue Aug 04 14:32:33 2004
++++ braces.c Tue Aug 04 15:15:36 2004
+@@ -402,6 +402,7 @@
+ {
+ pass_next = 1;
+ i++;
++ level++;
+ continue;
+ }
+ #endif
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index 6934c16e2180..567a2d564228 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bash
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/
diff --git a/shells/bash3/files/patch-braces.c b/shells/bash3/files/patch-braces.c
new file mode 100644
index 000000000000..591d58ef3888
--- /dev/null
+++ b/shells/bash3/files/patch-braces.c
@@ -0,0 +1,15 @@
+#
+# Fix nested brace vs. variable expansion
+#
+# http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00056.html
+#
+--- braces.c.orig Tue Aug 04 14:32:33 2004
++++ braces.c Tue Aug 04 15:15:36 2004
+@@ -402,6 +402,7 @@
+ {
+ pass_next = 1;
+ i++;
++ level++;
+ continue;
+ }
+ #endif