aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-01-17 15:17:24 +0800
committeradamw <adamw@FreeBSD.org>2013-01-17 15:17:24 +0800
commit1f8bd15331cca0985ac5b054f2fa649d1482c014 (patch)
tree0cb21b3d4206811dcfe2dcb3dfc2820f75406369 /shells
parent1455ca6955a708a01ad5fed65fa865ece63fa519 (diff)
downloadfreebsd-ports-gnome-1f8bd15331cca0985ac5b054f2fa649d1482c014.tar.gz
freebsd-ports-gnome-1f8bd15331cca0985ac5b054f2fa649d1482c014.tar.zst
freebsd-ports-gnome-1f8bd15331cca0985ac5b054f2fa649d1482c014.zip
Add support for WITH_BASH_DEVEL=yes to depend on shells/bash-devel.
Also, use MDOCS.
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 53079dec32c3..4f7da7b60f0d 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -12,7 +12,11 @@ MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
+.if defined(WITH_BASH_DEVEL)
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
+.else
RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
+.endif
CONFLICTS= bash-completion-classic-[0-9]*
@@ -25,6 +29,8 @@ SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
PORTDOCS= *
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -42,7 +48,7 @@ post-patch:
${WRKSRC}/completions/*
post-install:
-.if !defined(WITHOUT_DOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for i in README doc/bash_completion.txt doc/bashrc doc/inputrc
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}