aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2007-08-13 18:34:17 +0800
committermm <mm@FreeBSD.org>2007-08-13 18:34:17 +0800
commit2da9959241b63083ebb16e252c7016dd6c258ef3 (patch)
treece8ae142a50fd0cdb106bd9fbe86881e2fcc6721 /shells
parenta856ab11984ac14ca6eb4c05bc378acd270d1c84 (diff)
downloadfreebsd-ports-gnome-2da9959241b63083ebb16e252c7016dd6c258ef3.tar.gz
freebsd-ports-gnome-2da9959241b63083ebb16e252c7016dd6c258ef3.tar.zst
freebsd-ports-gnome-2da9959241b63083ebb16e252c7016dd6c258ef3.zip
- Add OPTIONS for included knobs
PR: ports/110036 Approved by: maintainer (timeout), garga (mentor, implicit)
Diffstat (limited to 'shells')
-rw-r--r--shells/scponly/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index fc2b66296706..88f32af3173a 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -71,7 +71,7 @@
PORTNAME= scponly
PORTVERSION= 4.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= http://www.sublimation.org/scponly/ \
${MASTER_SITE_SOURCEFORGE}
@@ -84,10 +84,20 @@ COMMENT= A tiny shell that only permits scp and sftp
MAN8= scponly.8
GNU_CONFIGURE= yes
-PLIST_SUB+= SCPONLY_CHROOT="@comment "
PATCH_STRIP= -p1
+OPTIONS= SCPONLY_WILDCARDS "wildcards processing" on \
+ SCPONLY_GFTP "gftp compatibility" on \
+ SCPONLY_CHROOT "chroot functionality" off \
+ SCPONLY_RSYNC "rsync compatibility" off \
+ SCPONLY_SCP "vanilla scp compatibility" off \
+ SCPONLY_SFTP_LOGGING "sftp logging compatibility" off \
+ SCPONLY_SVN "subversion compatibility" off \
+ SCPONLY_SVNSERVE "subversion compatibility svn+ssh://" off \
+ SCPONLY_UNISON "unison compatibility" off \
+ SCPONLY_WINSCP "WinSCP compatibility" off
+
.include <bsd.port.pre.mk>
.if defined(SCPONLY_DEFAULT_CHDIR) && !empty(SCPONLY_DEFAULT_CHDIR)
@@ -103,8 +113,10 @@ CONFIGURE_ARGS+=--disable-gftp-compat
.endif
.if defined(WITH_SCPONLY_CHROOT)
-PLIST_SUB= SCPONLY_CHROOT=""
+PLIST_SUB+= SCPONLY_CHROOT=""
CONFIGURE_ARGS+=--enable-chrooted-binary
+.else
+PLIST_SUB+= SCPONLY_CHROOT="@comment "
.endif
.if defined(WITH_SCPONLY_RSYNC)