aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-03-25 03:48:12 +0800
committerknu <knu@FreeBSD.org>2004-03-25 03:48:12 +0800
commit1748400751a1087da8f29357ff693343b7a0e028 (patch)
tree87bb39cc44cb2b4b3e016415b8c11ae49a88220a /shells
parentfc03579431bfd5dfb646a3a898d492a27f0f8ce7 (diff)
downloadfreebsd-ports-gnome-1748400751a1087da8f29357ff693343b7a0e028.tar.gz
freebsd-ports-gnome-1748400751a1087da8f29357ff693343b7a0e028.tar.zst
freebsd-ports-gnome-1748400751a1087da8f29357ff693343b7a0e028.zip
Add a patch to fix a minor bug with deleting a multibyte character at
BOL.
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh+euc_hack/Makefile1
-rw-r--r--shells/zsh+euc_hack/files/patch-Src::Zle::zle_misc.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/shells/zsh+euc_hack/Makefile b/shells/zsh+euc_hack/Makefile
index 1b8e3827d76c..210437c85ffe 100644
--- a/shells/zsh+euc_hack/Makefile
+++ b/shells/zsh+euc_hack/Makefile
@@ -8,6 +8,7 @@
MASTERDIR= ${.CURDIR}/../zsh
PKGNAMESUFFIX= +euc_hack
+PORTREVISION= 1
MAINTAINER= knu@FreeBSD.org
COMMENT= The Z shell with EUC encoding support
diff --git a/shells/zsh+euc_hack/files/patch-Src::Zle::zle_misc.c b/shells/zsh+euc_hack/files/patch-Src::Zle::zle_misc.c
new file mode 100644
index 000000000000..e19b39fefcea
--- /dev/null
+++ b/shells/zsh+euc_hack/files/patch-Src::Zle::zle_misc.c
@@ -0,0 +1,17 @@
+--- Src/Zle/zle_misc.c.orig Mon Sep 10 19:48:51 2001
++++ Src/Zle/zle_misc.c Thu Mar 25 04:36:46 2004
+@@ -94,6 +94,14 @@
+ return ret;
+ }
+ if (cs + zmult <= ll) {
++#ifdef ZSH_EUC
++ if (locale_is_euc) {
++ if (zmult == 1 &&
++ _mbmap_euc[line[cs]] & _MB1 &&
++ _mbmap_euc[line[cs+1]] & _MB2)
++ cs += 1;
++ }
++#endif
+ cs += zmult;
+ backdel(zmult);
+ return 0;