aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-06-19 02:50:26 +0800
committernork <nork@FreeBSD.org>2005-06-19 02:50:26 +0800
commit65d8e3312783e546ffc8e8a1418e19dea378fe37 (patch)
treed58bf663ed6945ff38164fdf583ac77422bcb34f /shells
parenteaf83007839fc54bfd258d816ce5c924b53432ef (diff)
downloadfreebsd-ports-gnome-65d8e3312783e546ffc8e8a1418e19dea378fe37.tar.gz
freebsd-ports-gnome-65d8e3312783e546ffc8e8a1418e19dea378fe37.tar.zst
freebsd-ports-gnome-65d8e3312783e546ffc8e8a1418e19dea378fe37.zip
Add support ssh+svn://.
PR: ports/81889 Submitted by: Matthias Fechner <idefix@fechner.net> Approved by: rushani (maintainer)
Diffstat (limited to 'shells')
-rw-r--r--shells/scponly/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index bf330567a79b..f784dcb638e1 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -48,6 +48,10 @@
# default: undefined
# define if you want to enable subversion compatibility.
#
+# WITH_SCPONLY_SVNSERVE
+# default: undefined
+# define if you want to enable subversion compatibility with svn+ssh://
+#
# WITH_SCPONLY_UNISON
# default: undefined
# define if you want to enable unison compatibility.
@@ -115,6 +119,11 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
CONFIGURE_ARGS+=--enable-svn-compat
.endif
+.if defined(WITH_SCPONLY_SVNSERVE)
+BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
.if defined(WITH_SCPONLY_UNISON)
BUILD_DEPENDS+= unison:${PORTSDIR}/net/unison
RUN_DEPENDS+= ${BUILD_DEPENDS}