aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-12-15 16:23:29 +0800
committerobrien <obrien@FreeBSD.org>2003-12-15 16:23:29 +0800
commit82a33f9cd322c6c43f9dca63133dd5e50238fa53 (patch)
tree57e5f61f3c985b550b5b2cff8ed3c246840ddef2 /shells
parent8e508c2e9158165fdf7452c28858235ccf8975e8 (diff)
downloadfreebsd-ports-gnome-82a33f9cd322c6c43f9dca63133dd5e50238fa53.tar.gz
freebsd-ports-gnome-82a33f9cd322c6c43f9dca63133dd5e50238fa53.tar.zst
freebsd-ports-gnome-82a33f9cd322c6c43f9dca63133dd5e50238fa53.zip
Also pay attention to NOSHARED=yes as /usr/src and zsh does.
Requested by: Richard Coleman <richardcoleman@mindspring.com>
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash2/Makefile2
-rw-r--r--shells/bash3/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index bfc39444345f..b3066ea38177 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -34,7 +34,7 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
-.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ( ${NOSHARED} != "no" && ${NOSHARED} != "NO" ))
CONFIGURE_ENV= LDFLAGS=-static
.else
CONFIGURE_ARGS+= --enable-static-link=no